Keep getting prompted for Username and Password

Logging into our production environment, I keep getting prompted in Kinetic/Home mode, for a username and password into our domain, but no matter what you enter, the prompts keep coming back. You can close them and still get in, but they just keep popping up. This does not occur in Test and the environments are almost identical.

Using Https Endpoint Binding/HttpsBiinaryUsernameChannel but switched back to Net Tcp Endpoint Binding/UsernameWindowsChannel but I still get the issue. This also only occurs in Kinetic/Home, it does not occur in Classic or Modern.

Not sure where do look next, I feel like I have gone through everything (obviously not, or else it would be working). Please help if you can.

What Authentication is switched on in the IIS for this application? Is it different from test or pilot?
You only need Anonymous on.

1 Like

thank Olga, sorry for not getting back to you sooner, I was out last week but I am back now. I tested, removing “Windows authentication” from production (though test had it enabled), did an IIS Reset and tested again and got the issue again. Still looking through for issues, but would you happen to have any other ideas?

Interesting thing I just discovered,

Image #1 and #2 is Production, #3 is test. Notice how one shows an executable named epicor.exe, 2nd shows a blank name (epicor.exe above it) and #3 shows Kinetic. I am thinking to delete Production, reinstall it (I will be doing it now) but would you have any idea why this may be? just in case, I have “Home Page” selected for both environments logging in.

The same thing has been happening to me lately … only me though. No one else seems to have the issue. I have no idea where to even start with fixing it.

thanks for chiming in WendyB, I am getting on a call today with Epicor to see if they can help. I have cases up, but they have not been any help on those. If I learn something I will update this post. I believe it to be something on the SSRS side but I am not 100% sure.

1 Like

Good luck! I have a call with a consultant this morning on a different subject but I will see if he’s ever seen this and has any input.

1 Like

Check out

1 Like

sadly that did not work and the support team was not able to help out, yet at least, they are checking with their other team and get back to me. They believe it to be tied to the login screen (what shows up there) and maybe favorites too. I tried to go back to default log in screen (which would make sense as to why you are the only one with the issue) but i cannot get a different screen for some reason. @WendyB

Do you have same popup window when you open home page in standalone Chrome?

1 Like

I apologize for the stupid question, but I completely forgot how to access it from a browser, could you remind me?


sadly yes i still get the prompts, just looking a little different

If you click on F12 in browser, it will show you the Dev Tools. There is Network tab, that shows all server requests. Failed requests are shown in red. Can you post an example of URL that is shown in red and Ststu code is 401.
Example without error:

you are a genius Olga (though I know you have heard that a trillion other times), this is what I see


Sorry, but I don’t think Edge Agent (that wss://localhost… link) is involved. It tries to connect and then just not used.
Go to Network panel and look for 401

Well, I am closer but I dont see a get table list, should I be focusing on the red text on the left

oh Also, I dont see any 401’s, only 404’s

Table list was just for example. you will have another calls.

Try to refresh the page without closing dev tools. The NEtwork tab will also refresh. Look there for 401 again.
Also probably it is better to check Preserve log checkbox in the top pf network panel, so calls will not dissappear after page redirects. Then refresh page to see all calls from start.

Ok, I found 401’s, notice, the issue seems to occur after…, if that matters