Kinetic Dashboard not cascading

Good Morning All,

We are slowly trying to migrate over to Kinetic forms from Classic. In doing this, I am also exploring Kinetic Dashboards. I have 1 in particular that is showing odd behavior. The dashboard works fine in Classic, It opens up grid 1 with a BAQ. It broadcasts a Job Number and Grid 2 is filtered on that Job Number (data from BAQ). Grid 3 is filtered on Grid 1’s Job number also( data from different BAQ). Grids 2 and 3 have 1 entry each as expected.

Now the Kinetic dashboard glitch.
Grid 1 opens with all records from BAQ… Good
Grid 2 opens with ALL records from BAQ…Bad
Grid 2 opens with ALL records from BAQ…Bad

Highlight line 2 from Grid 1 and the filters take effect… OK kinda. If you are after the data in line 1 of grid 1, you have to scroll a lot…

I can hear the next suggestion… Make a Parameterized BAQ(s)… I tried that, Kinetic dashboard asks for parameters on every line change from Grid 1.

Has anybody else run across this ? Am I missing something ?

Thanks in advance


Can you share how you set the where clause from grids 2 and 3?
You can find that within Grid Model > Provider Model > BAQ Options.

Is that in Application Studio ?? I was working from Dashboard Maintenance. I deployed the same dashboard as Classic and App ( Kinetic)

Yes, that would be in App Studio. I haven’t tried to convert a classic dashboard with pub/sub to Kinetic, but they’re set up quite differently manually. I’m curious to see what the converter did.

I see the options you spoke of. I was just following the same process to deploy a Kinetic dashboard as I had used for Classic. Ah the learning curve… :crazy_face:

Looks like using the parameterized BAQ’s would be more efficient in the long run.
Its odd that the conversion to Kinetic works in a parent-child relationship AFTER you change focus on a grid column. Maybe a way to force a child refresh ??

No, it should be on load. That’s why I was curious to see what your where clause looked like.

Here is the where clause in Grid 2

Is that it?

It should be setting it to a field in grid 2.
For example:


**Edit - I’m not 100% on this, but it also feels odd that it’s coming from TransView.
I’ve seen it like this:


Here is a screenshot for Grid 2

1 Like

Ohhh, gotcha.
That makes sense; I was thinking you were up one level.

Like I said, it works, just have to bounce the focus a couple times

That makes sense because it’s pulling from TransView which needs an action to write to it the first time around.

Try changing it to this and see if that works:


No dice, wont filter

Okay–I’ll see if I can whip up an example after this meeting.

No problem, still getting an education on the workings of Kinetic Stuff. With what we have gone over, I may be able to get the parameterized BAQ’s to work…

Thanks again


Okay, verify your data matches up with this example.
It will be similar, but not exact because I’m in Quote Entry vs a dashboard, but the concept should be the same.

Make sure Query1 has a DataView set up (it should be done automatically from the converter).

Make sure that your grid for Query1 is bound to that DataView in the Grid Model:

Then, make sure Queries 2 and 3 are referencing that proper DataView in the where clause (either inline like mine or in the list like your previous screenshot).

OrderHed_OrderNum = '??{RelatedOrders.OrderHed_OrderNum}'
BAQ2Table_BAQ2Field = '??{BAQ1DataView.BAQ1Table_BAQ1FieldName}'

The result should be this on load:

*** BLOOPERS ***
Don’t forget to only specify the columns you want to see or else you will get everything in a completely useful, not sarcastic grid. :wink:

Wow, short meeting :grinning: and " whip up an example"

One thing I noticed on your BAQ Options, You have a full where clause and on the converted one on my dashboard put the clause in the ‘Where List’ ( the option below the Where textbox with the …) . Let me check if this makes a difference…

Man, you’re not kidding. I was scheduled for a 45min meeting to “introduce myself” to the new hires. Not sure how that takes 45 minutes? lol
5 minutes. Any questions? No? Aight, I’m out!

It shouldn’t make a difference; they do the same thing, but the Where List makes it friendlier to add multiple filter conditions.

Tried full where clause. Now shows no records till change focus on main grid…