Kinetic Warehouse / Mobile Warehouse End Activity error

We are testing an AML Striker handheld that runs Kinetic Warehouse app. When I select a “started activity”, it will not allow me to end that activity. It gives me an error that says:

This activity is not associated with you, navigating back to home page.

Any suggestions on what could be the problem? I can use MES to end activity just fine.


Can you end the activity from the desktop MES?

Yes, I can end from MES.

Did you start the activity from the handheld too?

Yes. Started from the handheld, but not able to end from the handheld. I can end the activity in MES regardless if I started it on the handheld or not.

Please note that we are new to this and we’re trying it out to see if it will work for us. So maybe there’s a setting somewhere (either on the handheld) or buried in Epicor that is preventing this. But I’m still looking for it if there is.

My experience with job reporting in EKW is that your employee has to be in the resource group that the transaction is going against. However, all of our testing has been from the work queue to start activity and end activity. Did you make sure you used the same user and employee?

Check that you go to “started activities” in the menu option under labor if you start it and leave and come back later it appears to go there.

Where does the employee get added to the resource? I’m looking at Resource Group Maintenance and I don’t see anywhere except where it says Backflush Default Employee… but I don’t imagine that’s what you mean?

Here on the employee record:

It does then show up in resource group as a listed resource. There was at one point a “bug” that you could delete the employee out of the resource group so it didn’t actually use it.

Thanks for that. I tried setting my employee to report to the resource group and resource that is listed on the job. I’m still not able to end the activity from the handheld.

With that being said, I was able to start/end from the Work Queue. That should be good enough.

Here’s what I see in ours and please note I updated to the latest version last week.
Tap on the transaction
and then select end activity
I could then report quantity and save the transaction to close out the test job I left open from MES earlier today.

Does it allow you to End Activity without reporting quantity?
Our use case is that we install equipment on trucks. Often times, we have 3-5 different people working on the same truck at the same time and also often times, work is started/stopped without reporting anything complete. So that’s where my direction is. It seems to me that I can report quantity OK from that screen but I can’t End Activity.

No problems from what I can tell. It behaves the same here as I get with MES / data collection. Just tap on it, go to end activity and don’t report a quantity and it cleared out the transaction.

I do find EKW to be the never ending options in the setting menu so if you have something enabled to prevent a 0 transaction I could see that causing an issue. I reset it to default this morning on the one I’m using since I manually switched environments so not sure if that is a setting as I haven’t looked.