Menu Maintenance Customization now showing in list

Hello Experts,

I am currently working with Receipt Entry form customization when I am attaching my newly created customization to Menu it is not showing in the List. I have tried with All Companies checkbox as well but no luck. if anyone came across and got any solutions?.

Version -

I had this the other day. Check that the company for the menu short cut matches the company for the customisation. If the short cut is for a specific company In menu maintenance you can go actions create for this company (or some thing like that) to create a new menu short cut for the current company. Hopefully the customisation shows up then.


1 Like

Thanks Brett for quick reply. We only have one company in database and I am not creating new menu it not showing in stranded menu Customization list in menu maintenance.

Not at PC right now so I am going of memory…

Check the company setting on the menu short cut and compare that to the company setting on the customisation. I think they need to match (at least that was the problem I had)


Brett Manners
ERP Systems Manager

** Total Marine Technology**
1 Ambitious Link, Bibra Lake WA 6163
PO Box 3054, Success WA 6964
P: +61(8) 9411 6500 M: 0400 227 371

Please consider the environment before printing this email or its attachments.

1 Like

I’m sure you logged out and then back in - or at least “changed user”.

As we all know that menu changes don’t show until you reload, so I won’t even bother to suggest it. :wink:

Hi Calvin,

Tried same but no luck.

So the problem is that this dropdown doesn’t contain the customization you’re looking for?


Does anything show up in the Customization Maintenance?
(Sys Mngmnt -> Upgrade/Mass Regen -> Customization Maintenance)

Menu Maintenance is broken for several DLLs where you cannot apply customization - versions 200.8 - 200.11. The issue has been fixed in 200.12 under ERPS-95829 and there is a HotFix available from support.

Some of the Epicor UI DLLs contain references for multiple different Forms. Some of those Forms are internally addressed (not available for adding to a menu) and some can be externally addressed as the Form to load when a menu option is selected. Since the Customizations are keyed by Form name and not DLL reference, Menu Maintenance needs to know which Forms are “Externally” available in order to show the Customizations in the dropdown Combo. A change made in 200.8 was designed to address a problem with displaying the appropriate customizations and while that update corrected the initial reported problem, it caused a new problem for a handful of other DLLs / Forms.

1 Like

Have same issue in 10.2.300.7
Based on what I read here, and playing a bit, even though we only have (1) Company, when I tick the box for “All Companies” it then shows up as a Customization.

You can open the ones you already created, and go into Customization mode and “Save Customization As” and then give it another name, I use _A for whatever Revision it is, and tick that box! Now under Menu Maintenance it will show up in the Drop-Down and apply just fine.

Silly Rabbit!
George Hicks

Just FYI, that’s not the problem that @Rich is describing for a fix. The all companies thing isn’t a bug it’s intended behavior. For single company on prem users means you pretty much check all companies everytime you make a customization.

The problem that Rich is talking about , is when those steps (or alternatively making the company specific menu item) still doesn’t work because there was a filter that was messed up. That only affected specific forms.

I got that, but someone mentioned that they, like us, only have (1) company and it still does not work even when you select the Company on the Customization. I realize it is there for Multi-Company and how that works, but as a work-around for a bug, when you only have (1) company, marking that box allow the customization to show up. There is still some issue with Epicor for sure, but this allowed me to continue updating my customizations. Not a fix for everyone, your mileage may vary. :wink:

You have to copy the menu item in menu maintenance so that it’s a company specific menu. Stock menu items are not company specific (even in single company settings). So if you use actions, copy to current company, your original customization will work.

You just have to keep in mind that the software has to work for everyone, so some might be multi company and need this functionality. Epicor doesn’t set up single companies different, mostly because you may want to add a company later.


Just ran across this and the fix is no longer available, but support did give me a workaround.
I created an updateable BAQ to update the Arguments field on the Ice.Menu table.
You just add a “-c <CustomizationName>”. Worked like a charm!

1 Like

This appears to be the Ice.Menu table not BpDirective?

I am currently having this issue for Job Tracker. I have tried changing the customization and the menu to All Companies and specific to our company. Neither shows any customizations.

I have attempted to change the arguments in the Menu table and this will allow whatever I enter to show in the dropdown but the changes do not stick when exiting out and reopening and the arguments reset to ‘-ro’.

Is there something I am missing?

Dumb question … but needs to be asked…

You’re exiting the client and relaunching after every change? I find that changes to the menu don’t take until the next time the client is launched.

Aye, you are correct! I will edit my post. Sorry for the confusion.

Add the customization to the end of the -ro. Trackers have the -ro to stay Read Only.
Here’s what I have for my Job Tracker:

Yes. I have exited and relaunched whenever I make a change. I have also been clearing the client cache.

Thanks for your help @hmwillett and @ckrusen. It turns out I had the customization marked as ‘WIP’ which does not allow it to show up on Menu Maintenance. Its always the little things!


Never would have guessed that. I don’t think I’ve ever used that checkbox. :sweat_smile:

1 Like

Was that editable somewhere? Or did you have to do a Save As and not tick that checkbox?