Mfgsys64.exe on sql 32bit

Epicor support suggested running mfgsys64.exe on 64bit for our 32bit Epicor version. Are there any compatibility issues with doing this? It seems like Epicor does not like running on the 4.5 .net framework. What .net version is E9 compatible with?

According to the install guide I have for E9.05.702 it is .NET 3.5.

You might want to check out answerbook 13008MPS on EpicWeb too.
Some notes on mfgsys64.exe and E9 versions.

Any concerns running mfgsys64.exe on 32bit? Heard that the 32bit is only for server side client files and running Epicor through mfgsys64.exe shouldn’t cause any compatibility issues…?

depending on your version… maybe slower and some Crystal Reports issues
these answerbooks give some details - 15906MPS & 13008MPS

I have only used 64 bit on my own workstation, mostly as a curiosity.
and haven’t needed to deploy to other clients, so I just don’t know much about common other issues to watch for.

What kind of errors could be caused with using .NET 4.5 on E9? We have a user on the .NET Frameworks 4.5.1 but is not experiencing any issues on E9. And then we have others who are on .NET 4.5 and getting the mfgsys.exe error.

Have you tried setting compatibility on your client shortcuts?

  • Windows XP

As far as I know… a system with .NET 4.5 should be backwards compatible with all previous versions of .NET ( in theory ).
Not all versions of Windows are the same and in some cases you need to take extra steps to enable old functionality.
Here is an example link…

We did try running it in Compatibility mode and it did not resolve the issue. Some users are on Windows 7 and Windows 10 that are having the issue. Although we did run an install program that required us to update the ODBC Driver 11 for SQL Server (x64) which might be the issue if we are on 32bit? Would installing a 64bit ODBC driver impact Epicor running on 32bit?

I don’t see why it would impact the basic E9 clients.
You may want to check if you are using external BAQs, or Crystal Reports with ODBC.

What is happening? Crashing on startup Or during some operation(s), random?

Some PCs work and others don’t?
Have you compared Windows systems that work/don’t?
I’ve definitely had some weird Epicor problems on PCs from certain Vendors.

I’m assuming you’re already clearing user caches on a regular basis?

When we go and print preview the GL Book Listing report it then errors. Any Finance report will encounter the error when print previewing.

We did try to compare the .NET frameworks on the computer but it isn’t consistent. The install required Micrsoft Visual C++ 2015 Update 3 Redistributable Package and ODBC Driver 11 for SQL Server (x64). Those are the only two things that we can think of that might have impacted Epicor. Not sure why changing to mfgsys64.exe is a temporary workaround fix.

OK - Error details? - Standard - Crystal style(s)?

Can you use generate only and do these reports create XML files in the user directory?
If so, I would try opening the report in Crystal developer, then link to that XML file…
If XML works with the report in developer view (I’m guessing it will).

You might be looking at memory issues on the cleint
or a Crystal / .NET Runtime version issue rather than just the Windows .NET version

  • I’d check Crystal runtime version on clients
  • and the version of Crystal Developer are you using AND if all the SPs for that version have been applied
    — I’ve seen some issues depending on which developer version the report was last saved by.

Just the standard error message below. We try install the CR runtime (CRforVS_redist_install_32bit_13_0_14) on EpicWeb and that still did not resolve the issue.


Yes, this is exactly what I would expect from a Crystal Runtime issue/mismatch.

Just to be sure I would still check the users report data directory… I’m 99% sure that the XML file is successfully generated into that users directory and you could open the Crystal report in Crystal Developer, link to that users XML file & view the results successfully there.

So a few things you could think about

  • try 64 bit client setup… per your version of E9.
  • try uninstalling/reinstalling.Crystal Runtime(s) for the existing 32 bit client - you will find a few choices for download on EpicWeb.
  • and/or verifying the version of you Crystal developer for you version of E9 and re-save any the report(s) in that version of developer. (make backups first)

Note that the 64 bit client does use a different Crystal runtime depending on the E9 version. Probably why support suggested the 64 bit client in the first place.

That was our first guess at what was causing the issue too. Where is the users directory located on the PC Client to review if the xml file was generated? We are on a 32bit client so not sure what happened to need to open using mfgsys64.exe.

On the server, your Epicor share
Something like
…\epicor\EpicorData\Reports\UserName\Book Listing ReportXXXXXX.XML

I found the server but not the file directory \Reports so I’m not sure if I’m hitting the correct server. I am logging in through my PC Client install and not on the terminal server. We’ll have to try your second option of reinstalling CR for 32bit.

What’s involved in a 64bit client setup? We’re going to try installing the 64bit CR if that helps. We tried it with the 32bit last time and that didn’t resolve the issue.

Do you have access to EpicWeb?
If so… see AnswerBook #: 15906MPS
“How to implement the 64-bit smart client and 64-bit Crystal Runtime”.

We tried uninstalling and reinstalling Crystal Runtime 32bit and it seems to have worked. I wonder why the current CR for 9.05.702 version out on EpicWeb didn’t work when I tried reinstalling it originally. We had to install an older CR version to work correctly.

We had to uninstall first, simply reinstalling did not work?

Yes, I don’t know if I mentioned that but if I’m doing anything with the runtimes, I would typically uninstall everything and start the install(s) from scratch again.

And I watch for the selection… “everyone” or “just this user”.
Have seen this default to “just this user”… a common screw up.

Turns out that our Sage FAS upgraded to run Crystal Runtime 2016 which isn’t backwards compatible with our E9 Crystal Runtime 2013. Any workaround or should we do what is suggested of having Sage run on VM so they don’t conflict with different versions of CR on the local PC client?

1 Like