OnBlur not firing

Fairly new to App Studio. I’m getting my feet wet. I am trying to put a textbox in the Data Collection browser view… I tried the very same thing in the standard Kinetic browser view and it seemed to fire just fine. But I’m not having any luck here. I’ve tried binding it to various data views as well as leaving it unbound. Nothing seems to get the onBlur to fire. All I have in my event is to show an erp-message. Is there some magic to the onblur event?

Well, I found a different way. I ended up triggering my event using a DataTable Column Changing trigger. I set my custom textbox to TransView.Barcode (just made up a column name) and then I triggered on that column. Sure enough, I get my message box. Now, I graduate from here to figure out what else I can do with this information.

I am having the same issue with my custom boxes. I have one that is setup as a currency-box and I have no issues firing an event. I have another one I need to use and it is setup as a numeric-box and nothing happens. You found a work around using transview. Can you explain how you used it? I’m fairly new to Application Studio.

I’ll be honest, I have not done much in Kinetic. That was one of my first attempts to mess with events and I haven’t done much since. If I recall, the issue I was running into was that my textbox was not bound to anything - because I didn’t need it to be. I was trying to create a text box that would receive a barcode scan and then the goal was to take that scanned input text and parse it and do something with it. And since I wasn’t binding the textbox to anything, the normal logic events weren’t working right.

So the “hack” is to bind it to a non-existent field. TransView is a real view but Barcode was not a real field in the data table. But by doing that, you can then use the Data Table Column Changing event in place of the OnBlur event and then do what you want to do. Does that make sense? You can just type in the binding (you don’t have to select from the available fields in the drop-down).

I see what you are saying. The field I am using is not bound to any field in the database but I want to use the number entered in the field to do a calculation. I’ll give it a try. This is my 1st attempt too.