Optimizing Dashboard Loading: Minimizing Dashboard Refresh in Epicor Kinetic/ Disabling Auto refresh on Load Kinetic Dashboard

Hello EpiUsers,

How can we prevent the automatic refresh of a Kinetic dashboard upon form loading due to extensive data retrieval from multiple BAQs and tabs?
This refresh delay significantly impacts the dashboard’s usability. Are there any options or solutions to optimize the dashboard’s performance and minimize the loading time?

Dnyanraj Patil

Right-click on the dashboard query and select Properties. In the Dashboard Query Properties window uncheck the box for Auto Refresh on Load.

Hello @THulbert ,

Yes, I already took care of that checkbox; in the classic form, it functions properly, but in the Kinetic apps, it loads data automatically whenever the dashboard is opened.


I did something like this by utilising functions with a dynamic query adapter.


Hello @ridgea ,

Thank you for the workaround. I believe that is currently the best approach for dashboard refresh.

Dnyanraj Patil

Thanks @Dnyanraj_Patil , appreciated.