Overscheduled Resources

I’m trying to schedule finitely. Epicor is overscheduling resources from the very beginning of the schedule. I would understand overscheduling past my finite date or if a job was scheduled to end after the finite date, but these jobs that are being overscheduled are not.

This is from the resource scheduling board for resource M290.

This is the resource group:

This is the resource itself:

Site Maintenance:

And these are the settings when I run Global Scheduling:
image

If someone could point me to what I am missing or overlooking, it would be greatly appreciated.

My current steps are to Generate Shop Capacity, Process MRP, Calculate Global Scheduling Order, Global Scheduling.

1 Like

Your scheduled jobs are not completing on time. Are you selecting “Finite” when running MRP?

What do your calendars look like? Also, do you only have one resource per operation or more than 1?

This is my MRP parameters I run:

Currently using one schedule for everything.

Operations have more than one resource. The machine and a generic employee resource based on the capability. The generic resources I have set as infinite because currently I’m only concerned on getting a finite machine schedule. Originally wanted to do employees as well but trying for something simpler for now. We do have the APS module.

I would wait for someone else to confirm this, but I do not believe you should be checking off the actual “hours” that you operate. I believe you should just start at 1 and check off to 16.

You are going to have to get your infinite resources on an infinite calendar. The Finite and Infinite cannot be on the same one.

1 Like

The hour callouts do work. We use them, and jobs won’t schedule on off-hours. It is not advisable to have a gap on the hours, though, the 16 hours should be consecutive. But, they can be related to actual shop hours, and operations will not be scheduled to run on off-hours.

Have you tried regenerative MRP instead of net change? Can you afford to have your existing unfirm jobs go away?

I would run Regenerative MRP finitely, and check to see if the jobs are scheduling finitely. (The only item scheduled will be your unfirm jobs). Then, run the global and see if the same jobs are scheduled finitely. At least you can pin down which task is overloading your resources.

If that doesn’t identify the offending task, it may be a setup or configuration issue.

1 Like

Gil,
What is the reason for not having a gap on the hours? or what is the consequence of having one?

Thanks,

Check that you have the company config setting for Allow Scheduling Before Today as FALSE. It is on the Modules > Production > Job tab

As far as the gap on the calendar, we were told to not have any gaps and that a gap indicated the end of that day for scheduling.

image

I have it set to false.

So over the weekend, we rebooted the server and I tried to start fresh this morning. After running MRP with regenerative checked and the hours gap removed from my schedule, I get this for resource M290:
image

Not only are there still some jobs that are scheduled at the same time, but I have one job listed as starting on last Friday although I have everything checked to not allow scheduling in the past.

This is after running MRP. I have not ran global scheduling yet.

Your resource group lists seven resources. How many resources are being scheduled? What does the resource specification on the job operations say for resource callouts?

The jobs on your scheduling board are all released jobs, MRP won’t affect those at all. (Either that, or you have changed the

Are the unfirm jobs that were created by MRP scheduled finitely? Can you see where the unfirm jobs break past the finite horizon and begin to schedule infintely?

What does the shop load report look like for the resource?

2 resources of the 7 are scheduled. If you’re asking about capabilities, those two resources have capabilities required for the job that the other resources do not have. (They’re all saws, but not all have the same capabilities)

Looking at only unfirm jobs, they are being scheduled finitely and are not overscheduling.

I can’t see where to limit the shop load report to a single resource; it only allows me to drill down to a resource group. When running the report for the resource group, I get this result (I’m assuming you were only interested in totals):

Currently running global scheduling to see if it makes a difference with the firmed jobs.

That load report shows a finitely scheduled resource. With oodles of room to load more jobs.

Do your routings specify both the resource and the resource group on the methods?

I think you’re asking me about the job details > Operations > Scheduled Resources

I’m using capabilities instead of directly scheduling resources or groups.

Example of two conflicting jobs:
image

image

Hmmm… You are running 10.1.5? Now I am wondering, it seems like I heard about issues with capabilities in some earlier versions of E10? but… sorry, I can’t remember any specifics now.

FWIW,
I prefer to use a test system when playing around with my MRP/Scheduling.
Freedom to “get creative” without worrying about any consequences.
I also like to run the highest logging levels for my processes. Occasionally have spotted some obvious “stuff” in the logs.
image

I am on 10.1.5

I am using a test server for my scheduling and using the highest logging level: MRP and Scheduling but am not seeing anything in there that would explain what is going on. (at least from what I can tell)

What does the resource list on that particular capability look like?

That is the only resource with this capability. I understand that this will make it the bottleneck but I would think that it would still not overschedule the resource, just push all the jobs out further while they work through this resource.