Print Preview doesn't work with certains SOs

There are some old SO I can’t print preview. They have no Shipments and in Order Detail the Total is 0.00, but in the line 1 there is a Total Price wich is correct. Does anybody know why? And what should I do, please. Thank you

Do you have custom report styles for your sales order acknowledgements? Have you tried using either a custom style, or the default style?

Sometimes a report includes a calculation that uses division. Computers hate trying to divide by 0, so anytime a 0 is included an the report won’t run, I assume it is a divide by zero. Unfortunately, there isn’t an easy way to identify the offending field.

If you have custom styles, and the issue is with one of them, I would take a close look at the style in report builder to see if there are any calculated fields in there that use a division.

If you do not have custom styles, and this is happening on the default order ack style, then I would hit up Epicor support. It could still very well be the divide by zero issue. Maybe just filling in a missing field in your sales order will help.
Good luck!

OrderAck will not print if the Line Items are “void”. For example, If your sales order only has one line… and you “Close” the line item from the overflow menu, Epicor checks a VoidLine checkbox in the background… with no valid line items, Epicor won’t print the OrderAck.

You said these were older SO’s. are the lines closed? Does the order show as void?

1 Like

In system monitor, does it succeed with no report or fail with an error? In the latter case, what’s the error?

1 Like

Is the the default order ack style. Thanks

elvia, did you look at @SteveFossey 's question?

The SO is closed and you’re right: the SO Void checkbox is check

There is no error. It simply looks like doesn’t work. I click in Print Sales Order Ack and happens nothing. It appears in the Notifications bell and nothing happens when I click there too.

Eliva, open the system monitor in your sys task tray:




Ah, you are in kinetic? “Notifications Bell”

There is still a system monitor there and you should see a column in the history tasks that says status and it should say ERROR in your case, but if it says COMPLETE then I am not sure.

So… the ORDER shows as void… but that’s not what’s preventing the printing.

Its because the LINES are void.

I just “fixed” this in my system using a BPM (as suggested here by @DaveOlender)

1 Like

1 Like

Even if I can print other SOs?. Because the problem are only with certain old Sales Orders

Here’s the BPM details:

This just forces the VoidLine checkbox to always be false.

With that BPM in place… test it out:

  • Open a Void Order
  • Overflow menu > Reopen Order (this will un-void the order)
  • Go to the Line Details > Overflow Menu > Reopen Line (this will un-void the line)
  • Overflow Menu > Close Line (this typically would VOID the line… but the BPM will now allow the line to close, but will keep the VoidLine checkbox unchecked).

This Sales Order should now print.

1 Like

@dcamlin is stating that voided lines can be a problem. you need to use the system monitor to tell you what the problem is, have you opened the system monitor to look at the task?

Oh, yes! I hadn´t seen this before. And there is an ERROR : "No Order Details record found for Order = 2 "

1 Like


This is where my expertise ends on this Elvia.

But at least you now know how to look into errors using the system monitor. So now you can open an Epicor case or post that on here and get help from great minds like @dcamlin

If that works… and you have a lot of orders to “fix”… you can use DMT.

DMT template for OrderDtl with columns:

  • Company
  • OrderNum
  • LineNum
  • VoidLine = False
  • OpenLine = False
  • PartNum (required by DMT)

Just create a BAQ against OrderDtl and gather those columns (where VoidLine = true)… export results to excel… make sure your headings are correct. Then run the DMT.

I first though I’d have to run multiple DMTs… re-open the orders, re-open the lines, re-close the lines… but tested it and was able to do it all in one shot.