Printing Win 10

Couldn’t find anything mentioned, but we have a couple people who got new machines and I got Vantage 8 on the new Win 10 machines, but some reports when they are tried to be printed or even print previewed, it closes the app completely, no error, nothing like that at all.

Nothing in event logs either.

Worked on other people’s machines with no issues, not sure what is different about this machine from others we did previously with 10.

Is the Vantage client running on the affected machines in Compatibility mode?

yeah, tried XP SP3 and Win 7 compatibility modes.

install the 32bit CR Runtime

here’s a link (copied from an old email, so might not be current)

Here’s the 64 bit version (but you want the bit depth to match the bit depth of Progress, not the OS of the workstation or Server)

install the Crystal Runtime Service Pack
set the V8 client shortcut to run in compatibility mode…

Just one thing in addition to what others have already mentioned

I’ve had issues where a Crystal report has printer specified in the page setup.
i.e. some clients were not able to connect to a network printer
So… I go to Crystal Developer page setup for all custom reports and specify “No Printer…”

I am having this problem as well. Everything seems to work fine in Vista until I try to print or print preview. Then Vista just shuts down. No error messages.

I’ve tried installing the most up to date crystal reports run times and I’ve tried installing Visual C++ 2005 redistributable (those that it would let me). I have tired running in different compatibility modes. No luck.

I am running Vista 8.03.408B Has anyone discover what is happening?

Any help would be appreciated.

I assume you mean just the client program on your computer, and not a total crash of Vista.

If you choose to generate the report - this is different than printing or previewing - does it still shutdown?

I forget what V8 print windows look like, but here’s an E10 one:


Thanks for the prompt reply.

Yes, the client shuts down. The server doesn’t crash.

I just tried a generate only and it did NOT shut down the client.

It seems to generate the report and if you are doing a preview, sometimes you can actually see the report preview for a split second before the Vista client session shuts down.

Re-launch the client, and open the System Monitor (should be able to double click the icon in the SysTray)

Go to the Reports tab, select the report that successfully generated, and try to preview it.

The report is showing on the system monitor list. When I click and hit preview, the client session closes again.

Kind of an aside, but when the session closes, I don’t have to clear out the license on the server like I do if something in Vista locks up and I have to shut down the client without closing Vista first. When the session drops out, its like it was closed properly if that makes any sense (or difference)

Is this problem limited to just this one workstation?

Just your user (regardless of workstation)?

It is only on a new laptop. This is our first Windows 10 machine.

I just tried to open the report in Crystal Reports XI Developer and got an error

It says "\server\epicomfgsysdata\reports\user\xxx.XML. This document could not be opened. It does not appear to be a Crystal Report document. This document has an unexpected file extension. Probably is not really a crystal report document.

I was doing that wrong in CR XI developer.

When I open the correct report and then preview the newly generated .XML file, it previews fine and I can send it to the printer fine.

Try installing the 32 bit version of the CR runtime. And make sure you do so with Admin rights

I downloaded and installed CR runtime engine for .Net Framework (32-bit) and (64-bit) from SAP earlier.
They are version

I will try reinstalling

Tried reinstalling – still shuts down.
Tried removing 64 bit and just running 32 bit --still shuts down.

This is a puzzler to me.

I have to head home. I appreciate your help. If you think of anything else, leave me a message and I’ll try it in the morning.

Thanks again

Possibly try an older version of the CR runtime - I’ve always matched the CR runtime version to the version of Epicor. I’ve only used the product since v9 though, so not on Vantage.


Ok, I uninstalling everything (all versions CR Runtime, Epicor Client, .Net 3.5, and WSE 3.0 Runtime).

I made sure my printer was set to “default printer” and that it would actually print correctly from a web browser.

I then reinstalled everything on my Epicor 8.03 disk. This would be the client, the .Net 3.0 (which changes to 3.5), the WSE 3.0 and the CR XI R2.

I tried a print preview and it shut down my client as it has been doing. A few minutes later a message from windows said it was going to run the program in a different compatibility mode next time. I ran it again, and it works!

I had tried different compatibly modes before (setting them manually) and nothing worked. Windows set it to XP SP3 which I tired already, but whatever. Its working now.

I think the main problem was not having the printer set up prior to installing the client software.

Thanks for everybody’s help.

1 Like

Now I have a slightly different problem. Printing/Previewing only works if I run as an administrator. I never had this requirement in XP or Windows 7.

Any ideas on how to change this?