RMA Processing Kinetic Upgrade

When we go and create a new RMA the next number isn’t being used.

Is there an upgrade conversion process that needs to be run to set the next RMA number?

Not sure about a conversion, but you could just set this number to sync up to what you see in SQL.

1 Like

Hmm may try that.

We can create RMAs through Case Entry with no issues. (which is what I think is creating the number gap from what the system thinks is; the next number vs what is already there) Almost seems like the system is looking at a different table value to determine the next RMA Num.

Epicor field help is a bit unclear, as I think there are typos.

When creating a new Return Authorization the user is prompted for a Return number. If the field is zero , the next available # is assigned by the system. The system generates a number by finding the last CRAHead on file and uses its RANum + 1.


I wonder if CRAHead was an older table name for RMAHead and they just didn’t update the field help? :thinking:
I see that every so often. “XYZ field–place holder for new field in Vantage.” Yeah–okay. lol

It says if one is not entered, it takes the next. What happens if you enter 10793 and make dummy RMA, then make a new one and let it autofill? Does it fix the sequence?

I was forced to update the RMA number in the company config to create a RMA manually.

Was able to create another RMA using zero!!! Now I am going to create a few RMA from Case entry to see if this can be broken again. lol



Well now that side is broken. lol crap now I need to undo what I just did.

It’s interesting that creating an RMA from Case vs RMA Entry is different. Very sus. ← Look, I’m hip using “sus”. :rofl:

Thanks for the help!!

It seems to be working now.

1 Like

I’m just now running into this issue. Do you or @knash happen to know what Business Object is being used when creating an RMA from the Case Entry application? I created a BPM on RMAProc.GetNewRMAHead and we realized shortly after that this BPM wasn’t being triggered when creating RMAs through Case Entry.

Edit: I found it under HelpDesk.CreateRMA method but still no luck in getting the BPM working. It is a simple Set Field BPM.

HelpDesk.CreateRMA is the one. What is BPM trying to do?

1 Like

I created a CreatedBy field in RMAHead table. All it does is take the current user and populate the CreatedBy field when a new RMA is made. This works just fine on GetNewRMAHead. I cannot get it to work when an RMA is created from Case Entry.

I thought the HelpDesk.CreateRMA method would solve my problem but it still is not working. There is also a method HelpDesk.GetNewHDCaseRMA but I could not get this to work either. I have tried creating BPMs on Base and Post Processing and used the following selections in the Set Field BPM setter.

Any idea what my problem may be? Thanks for the response.

Why not use a datadirective here?

on RMAHead

Well, I thought I had tried that. I did not realize Standard and In-Transaction data directives had different setters. I had tried a Standard data directive and there was no ‘Set Field’ option available. Now using Set Field in an In-Transaction directive and will have a user test some different scenarios, but believe it should work. Thanks knash.