Running Kinetic from a Web Browser: Answer: Here is how

This question seems to come up all the time… so I will answer it before you ask.
How do I run Kinetic from a web browser? (or “Can I run Kinetic without downloading a client?”)

Yes, you CAN run Kinetic without a downloading a client, as long as the application you want to run has been converted to Kinetic (there are still a few that are not converted yet).

To run from a browser, you simply need to go to your favorite web browser (I use some version of Chrome… google, or MS Edge) and enter the web address for your server…

WAIT… what is that address? Well… the answer may be showing on your current installation. It is either at the top or the bottom of your screen. If you are in the “classic” client, it should be at the bottom (make sure that you have it turned on to display… see picture below). If you are in the Kinetic Home Page, then it will be at the top.

Anyway, the point is, you get the server address… then turn that into a full URL
If your address is:
abc.EpicorCloud.net/MySite
Then you type in the following into the browser (and save to favorites):
https://abc.EpicorCloud.net/MySite/home
But what about MES? How do you get there?
Similarly, you use the same as above but with more on the address:
https://abc.EpicorCloud.net/MySite/home/*/login?mode=mes

You enter the address into a web browser of your choice, BOOKMARK it, and use it.

16 Likes

Thanks Tim. Appreciate this post and I do have both regular and MES types setup to test as URL’s.

We are not live yet, but the URL feels twice as fast in testing. I am not sure how useful it will really be though until all the base screens are converted to Kinetic.

It is my goal to have this as the main way we connect, hopefully before we go later this year.

2 Likes

Brad… the URL is faster than accessing from client, so your “feel” is correct. Once the system goes GA, most of the mainline processes should be in the new UI and accessible from a browser. Those remaining (at first) will be mostly in Technical areas which should be coming soon after that.

tim,

does using the link for MES chew up a full liscense? It seems to do that on my end which is totally useless. I have 12 data collection licenses, and it seems like those will be garbage if I am trying to use the the URL links for MES.

well, when you use MES, it SHOULD be consuming an MES License, unless one is not available. I believe if all the MES Licenses are consumed, then it will roll into non-mes licenses.
make sure that you completely log out of your non-mes license before testing MES, otherwise, it might be retaining your previous session.

Checking in session management, there is plenty of licenses left for data collection. But as soon as I login using the URL link for MES, it consumes a Default… Pretty soon my defaults are all used, and the thing won’t login at all, even though there are 11 data collection licenses available.

Hmm… you should submit all service call on this. maybe something not quite setup correctly.

I have. They have said about the same thing, That it should not be doing that…

I struggled with this a bit. What I got to work is:
https://abc.EpicorCloud.net/MySite/home/#/login?mode=mes

It also does use a regular license. Using the shortcut on my start menu (/DC) option, the client uses a data collection license.

Using https://abc.EpicorCloud.net/MySite/apps/MES gives me a limited MES screen but consumes no license.

Note: I’m on prem, not cloud.

3 Likes

Thank you for sharing your MES link format as I too was struggling and your example did the trick!

We’re getting ready to update to Kinetic from 10.2.600. While I was testing I tried to open Kinetic in a browser and kept getting the dreaded 403 Forbidden error. There were a couple of things I needed to tweak in setup but while it works with Edge it’s still a hard no with Chrome. Any suggestions on how to make Chrome cooperate are greatly appreciated! Edge is not my favorite …

1 Like

Is there a similar switch like mode=mes for CRM?

1 Like

@Doug.C
on prem i use
https://EpicorServerPath/EpicorInstance/Apps/ERP/Home/#/home?app=mes

While Kinetic on the browser is really amazing. I have even tried out creating some BAQs on a browser screen and was pleased with the intuitive approach of the new UI.

Sorry to report though that MES is not ready for prime time on the browser. Some functions do work, but logging in, starting and completing an operation have caused additional pops up.

I have had a ticket open since Dec. 2021 to see if we could get an issue address to use MES on android tablets, but the fix is not due out until 2022.2 (November?).

I should note - that this is for SaaS customers that I am working with. (several)

1 Like

Glad to hear that you like the BAQ editor… We have done some internal reviews on the BAQ Screen, and I will note that not everything is as smooth as we hope to have when it is finally fully released. I too have created multiple simple BAQs using the new UI, and found that it takes slightly longer than what I am used to, but we hope to improve that.