Service Connect Order Reserve Workflow

Hi All,

I am working on a SC workflow for auto-reserving orders. I followed the trace log and am using the methods that look they are doing the work. There are two primary methods. I hardwired the nodes in the dataset as the tracelog has the values and am feeding the order number information. The workflow does not error out but it doesn’t reserve the order release. I do have an ‘A’ on the first RowMod and a ‘U’ on the second RowMod, like the tracelog does.

The last refresh bit was added as an experiment and don’t believe is necessary.

I also tried to follow it in the BL Tester but it processes without error and doesn’t reserve the material, like the workflow.

There are a couple of object/Methods prior to the CheckDates on ClassAttributes but when I run them they all return nulls so they don’t appear to pass any data forward.

Anybody have any results with something similar or know what to look for?

Thanks,
Ross

Hello Ross,

As per your scenario there are some extra checkboxes that you need set true.
As I remember one is “SelectedForAction” checkbox (OrderAllocDataSet/OrderAlloc) and RowMod set as “U”.
Please also check the trace log/file if there any other checkbox/field.

One more thing if you are reserving Sales Kit Part(or BOM) then you need to reserve all parts in one go.

Thanks and Regards
Dnyanraj Patil

Hi Dnyanraj,

Thanks for the response. I do have Selected For Action set to true and the RowMod set to “U” I followed the trace log and checked every field. There are no errors but it doesn’t reserve.

Do you have a working model?

Thanks,
Ross

Make sure DemandType is set to “Order”, other valid values are “Job” and “Transfer” but I assume you don’t use those. And as mentioned SelectedForAction should be true.

The AutoReserve method has an output parameter called cMessageText, this contains a message with the total amount of success/error records processed.

Hi Jonathan,

I do have the DemandType to Order and am not getting any errors out of cMessageText. Here is my conversion data:

Check Dates:

AutoReserve:

I will keep working at it.

Thanks,
Ross

But does cMessageText has the correct number of orders to process or does it say 0?

Does it say “0 Demand record(s) reserved”? or “1 Demand record(s) not reserved”?

Review OrderRel.PickError for the order you tried to process? What is the value?

It says “0 Reserved. 1 Not reserved” However, it reserves with the FWB interface.

OrderRel.PickError has a ‘P’ in it.

Ross

Jonathan,

It turns out it was only that I wasn’t specifying the plant and my last session must have been in the wrong plant.

When I changed the incoming Company parameter to Company=XX;Plant=XX it worked.

Thanks for the responses.

Regards,
Ross

2 Likes