Setting up Printers in Epicor

I am trying to add our server printers to Epicor Printer Maintenance, but it asking for a Network Path… I am not sure what that is. Or if I am even in the right spot to be adding printers.

I need to print checks, and can’t without having a printer set up. Can someone please help me!?

Share your printer from the PC it is attached to. The path is \PcName\PrinterShareName.

Hello Chris,

Thank you for this, but I think I am still doing something wrong… I have attached the info for the printer I am trying to add.

A few things. First I suggest a printer name with no spaces.

Next, from the server running epicor, can you ping server2? Windows+R >
type CMD and hit enter to get console. Then type PING SERVER2 and enter.
Did it get a response?

This is the Response I get.

OK so we can see the server. Try making a short simple printer share name.
Then update the path in epicor and try again. Also, how are you trying to
print in Epicor?

Okay, something is still not working… Am I typing the Network Path in correctly?

I am just selecting print then client printer.

Yep looks proper (so long as that FQDN pc name is valid). When you did ping, did you use that full name? server2.absoluteturn.local?

When you attempt to print - does it ask you to use Client or Server printers? If so, what do you select?

I don’t know how to figure out if the FQDN pc name is valid… I just tried to ping the whole name, Server2.absoluteturn.local, and it worked the same as when I sent you the picture before.

I choose Client Printer when I try and print.

Ah - So client printers will only show printers physically attached to that pc, server printers will show the printers you add in printer maintenance.

Okay, well I need to add a server printer. All of our printers here are on our server…

You already did. The printers you add in Printer Maintenance show up in the Server Printers list

But it gives me an error message when I go to actually print…

can you screenshot it

1 Like

Here is the screen before I print. I can’t actually screen shot the error, idk why. All it says it there was an error, like on the bottom right of my screen. Doesn’t say what the error is.

I noticed you didn’t have the checkbox to denote the printer as an SSRS printer on your config screen. @josecgomez probably knows the best way to proceed.

One last thing I would check is that you can install that printer from the share on another windows PC and make sure it prints a test page from it. Add printer in Control Panel and select shared printer by name

Okay, I was able to add the printer and print a test page from another computer using shared printer name…

From where are you attempting to print? Does a print preview work?

Just add the shared printer to the PC you’re using like Chris showed, then close and reopen Epicor. It’ll be in the Client printer list in Epicor. Just because it’s shared from the server doesn’t mean you need to use “server printer” in Epicor.


Mark Damen
ERP System Manager

Mobile: +44 (0) 7790 806926

BV Dairy ? Wincombe Lane ? SHAFTESBURY ? Dorset ? SP7 8QD ? UK
Switchboard: +44 (0) 1747 851855
Fax: +44 (0) 1747 851002


This message is intended for the use of only the person(s) (“Intended Recipient”) to whom it is addressed. It may contain information that is privileged and confidential. Accordingly any dissemination, distribution, copying or other use of this message or any of its content by any person other than the Intended Recipient may constitute a breach of civil or criminal law and is strictly prohibited. If you are not the Intended Recipient, please contact the sender as soon as possible.