Setup time and Scheduling Blocks issue

We have encountered and issue with how the system calculates setup time for our Labor based operations. It makes sense to us the idea of increasing the number of machine working on an operation will increase your setup time (two CNC machines, means double the setup). In the case of a labor based operation, Assembly cells in our case, adding more people to the job does not always means an increase in setup. Therefore how does one prevent the system from adding additional setup when we increase the scheduling blocks value on Assembly operations?

Currently if I have 20 minutes of setup on the Assembly operation and I increase the scheduling blocks to 3, the system will increase the setup to 1 hour. I would like to keep the setup fixed at 20 minutes for this particular operation. How does one accomplish this in Epicor 10?

Thank you,

Adam Jones

This is a challenging question… to compound the problem, in the database, the setup time data is stored as a TOTAL, not as a “per machine” value… but when it is displayed on the screen, it is displayed Per machine (I Just dealt with this yesterday in an updatable dashboard). Somewhere in the User Interface, epicor reads the Machine Count, reads the Estimated Setup, and calculates the Setup / Machine… If you change either the Setup per machine or the machine count, it calculates the total estimate (Machines * (Setup/mach)) for saving.
It may be possible to add a new field that displays the “Est Setup time” field that is actually saved.
Secondary option, make a BPM that forces your rules, and recalculates the est setup time the way you want it to be saved.