SSRS bug after upgrade last night (Cloud/Saas customer) End of Central Directory record could not be found

I’ve reported this already to Epicor, but thought maybe would be good to share.

We were upgraded to 2024.1.8

Any report style I change after last nights upgrade will not print, even with the smallest update

Gives this error

System.IO.InvalidDataException: End of Central Directory record could not be found.
   at System.IO.Compression.ZipArchive.ReadEndOfCentralDirectory()
   at System.IO.Compression.ZipArchive..ctor(Stream stream, ZipArchiveMode mode, Boolean leaveOpen, Encoding entryNameEncoding)
   at System.IO.Compression.ZipArchive..ctor(Stream stream, ZipArchiveMode mode)
   at Ice.Core.SsrsReporting.ReportProcessorBase.DeployReportIfNeeded(String printProgram, String fullReportPath, SsrsConfigurationInformation configurationInfo, Func`1 reportingServiceCreator) in ```

Uploading same report style to Production which is not yet upgraded and printing works fine
4 Likes

Thanks Scott, running into this today. Not a great week to be migrating reports.

3 Likes

?

And if that works, let’s compare the zip files so we can report it properly.

I tried it, no luck

1 Like

I was using Classic at the time, I’ll play with Kinetic-web

@bderuvo did you download, edit, and upload with Kinetic or just try a reupload?

This problem started for us yesterday when Cloud team upgraded our Third environment to 2024.1.8. They have stated it’s a known problem linked to Problem Number: PRB0284786

I am told that it is only affecting a subset of cloud hosted servers due to a failed upgrade to which they didnt follow their normal upgrade process.

Lets just hope the solve this and don’t replicate when they update our live environment next week.

2 Likes

@klincecum Just got back to this…so Report Styles in Kinetic-Web appear to be zip files ??? … ugh … now more steps in the process … I gotta download, unzip, edit, rezip, upload ? it was bad enough before…

On another note…today I exported a Kinetic layer from my Pilot/Test environment to my ERP/Production environment…it shows up in app studio landing page and menu maintenance, but when I launch it, it does not load, and when I launch it from app studio it loads the old version and when I do a ‘change version’ it’s not even listed !!!

Argh, ugh

4 Likes

@RyanMagin Yep, that’s the PRB they created from my support case I opened yesterday

2 Likes

You can open the ZIP and save the changes back into the ZIP. At least that’s what I do with 7-Zip but I think the built-in Windows one would do it too.

1 Like

Ok, that helps, 7Zip to the rescue…(I tried it with built in windows yesterday to no avail)…thanks

2 Likes

Today I tried modifying report using Kinetic-Web report styles upload/download.

It’s also broke for me

I downloaded zip file, successfully modified and saved RDL file back to zip, when I try to upload I always get:

image

1 Like

Where is Epicor on this? I guess that’s my question. What has happened and why are several people on this thread (and other threads on this site) now having issues?

I’m totally open to the fact that some of us may not have been downloading and uploading reports in the proper way (i.e. using the “design SSRS report” functionality to generate data and download/design the report), but is that what this is? Are we just doing it wrong?

It seems odd that all these people are having issues, but the reason is nameless.

I have an open ticket with Epicor:

Response from Epicor:
Issue is with a table getting records after copying/uploading the report, please upload the report you want to use and we’ll run a script to temporarily fix this, A permanent fix is bein created right now and it’s going to be applied for Live update so this doesn’t happen.

We expect to have the container build Tomorrow, so permanent fix can be applied this weekend, earlier next week.

We are web only, and we are currently in the state of if you upload any report, it will fail, regardless of the changes made to it

2 Likes

In addition it doesn’t matter if you upload via classic, smart client, web version. I’ve tested all 3 and they all fail to run when you upload them. The upload looks successful, however when you actually run them, you get errors.

2 Likes

@brian.w

thanks for the update from Epicor

@utaylor

I don’t think it’s related to “design SSRS report” you mentioned,
I’ve never used that, I always use report styles app to download/upload

I am curious what “design SSRS report” is though ???

2 Likes

That’s great, I forget if there is a central place with like degradation notes for cloud, kind of like a services impacted section for APIs…

Only the best functionality Epicor built in all of E10??
So you can have one app to download, preview changes, and publish, with no manual steps at all?

That’s “Generate for design” but yes it’s one of the better things they added to E10

image

2 Likes