Stock Status - Not Showing Inventory

I’m having issue with the stock status not showing inventory even though there are on hands. If I look at the part transaction history tracker, it is showing that I have on hands. When I run the stock status report, it indicate an error because no row is selected. We’re on version so not sure if there’s a known bug with this version. It’s not happening to all the parts which is kind of strange.

One thing I noticed is that if I go and create a PO for that part, received it into inventory, then it showed up on the stock status report. However, if I go and run the material queue or just wait for a an hour, it seemed to drop from the stock status report. One example, I have 15 on hands, but stock status indicate nothing and error. I went and received 5, ran stock status, and only the 5 showed up on the status report. I then received another 5 and that showed up. However, after running the material queue only 5 qty showed.
Waited for an hour and ran the stock status report and nothing. Any ideas?

One thing that happened to me a while back…

Noticed some parts weren’t showing up on stock status report.
Finally found that there was a mixture of upper/lower case entries of Whse/Bins in some the PartTrans for the part(s).

Once these were cleaned up, the Stock Status report behave normally again.

And discovered that the source lay in Receiving. Where some users were manually typing in the Whse/Bin from memory instead of doing a lookup/select. i.e. their entries were all lowercase, & didn’t always match the “case” shown in the master files.

I found a thread about that and it didn’t seem like that’s the issue. Checked in the PartTrans for Whse/Bins to make sure that it matches and no upper/lower case.

Just odd though for this particular part, if I change the date when running the stock status report to last year, I got -15. If I run it for today’s date I either get nothing or 5 shows. The first transaction happened 2/25/2019. So I should expect zero if I ran it for 12/31/2018, but I got -15. I checked the PartTran and no transactions until 2/25/2019.

1 Like

I found all parts with the field GLTrans = 0 in PartTran that it’ll error out if I tried to run the Stock Status report. Even though there’s inventory on hand, it will said no rows selected error. Any ideas what needs to be done?

Have you run the “Update Bin Qty’s” process? It’s in the System maintenance -> Rebuild
(Not sure of the exact name and location)

I believe it can be run in Report Only mode to show you what would be changed in the Update mode

Yeah I processed that for just the one part, but still nothing. I was also wrong about that GLTran flag. It’s a hit and miss. Some will run and some will not run. Did a SQL trace, at the table it’s pulling the data between part that run and part that does not run, I don’t see much difference.

Another thing with the Stock Status report, if I back date, I am getting negative quantities. For example, this part 1031915, the first transaction was on 2/25/2019. I have a qty of 20 in the PartBin table. If I run the stock status report for 12/31/2018, I am getting a negative 15. I would thought I would get nothing. If I run for today’s date, I get 5 qty and should’ve been 20. Does that report use the PartBin as a starting point or something?

Also looking at the part “Part Transaction History Tracker”, parts that don’t print on the Stock Status, the “Running Total” column is shown with 0 even though there are on hands. With the parts that print on the Stock Status, the running total is calculated correctly.

Okay found out that trailing spaces in the BIN will cause this issue. After doing a qty adjustment out and back to the bin, issue resolved.


FWIW - Stock Status Report works by taking the current QOH and backing out the part transactions that have happened since the “SSR Date” selected.

And because transactions can be back dated, running SSR with a specific date might not give the same results the next time it runs.

And most importantly… the unit cost is the current one, not the cost at the date it is run for.

1 Like

Thank you Calvin.

How did you find the mixture of upper/lower case entries in the Whse/Bins? We are having this issue and I ran both the Rebuild processes and that still did not resolve the issue. How did you find and know which one needed to clean up?

How did you find the trailing spaces in the BIN? I checked in Warehouse Bin Maintenance and did not notice any trailing spaces but could be mistaken so wondering how you found the trailing spaces?

[quote=“cchang, post:12, topic:54557”]how find…mixture of upper/lower case entries in the Whse/Bins
By Querying the PartTran table.

I have the exact same issue, Stock Status Report does not return information. I see that PartBin and PartTran had some records with what you mentioned (lowercases and trailing spaces) which I have corrected but I am still not getting any records on Stock Status Report. I even ran the “Refresh Part Quantities and Allocations” and “Refresh PartBin QOH from PartTran”, no luck.

Has anybody else seen different issues?

Check the trandate on the parttran records.

@ale_arevalo - Does your SSR report fail to print with the “No records” error in the System Monitor?

Or does it print, but parts you know to have on hand don’t appear on the report?

If it’s the last, use the Part Transaction History Tracker for one of those parts and see if anything jumps out.

Also, a couple of other things:

  • The options on the SSR form can be a little confusing. For example, the “Negative On-Hand Balances” shows only the parts with a negative net balance. Clear that box to show all parts with a non-zero net QOH
  • look at the tabs under the Filter tab, to make sure that it’s not being limited. If you find any, use Actions -> Remove Default on the menubar.

Hi Calvin,

In my case I see OHQ on Part Tracker, Part Transaction History and even going to PartBin tables on SQL displays on hand quantity but no matter what option I select on the Stock Status Report I always get the “no records selected” error, this is only happening on one of the Plants.

All parts are Purchased, have positive balance, they are not Non-Stock items but I have even tried leaving that flag checked:

TranDate would affect Part Transaction History, is this correct?
Running total for current day displays OHQ, I am trying to run it to current date, not even past dated. I really believe this is a bug, I was just trying to workaround it.
Stock Status report is so unpredictable.

Make a simple BAQ to get the current QOH. You only need the PartPlant and PartBin tables.

  • Company = Company, PartNum = PartNum
  • Add a table criteria to PartPlant to limit it to the Site in question.
  • Show columns:
  • Expression for calc field : SUM(PartBin.OnhandQty)

If that looks as expected, then look into the CostID used by the parts. Each site specifies a Site Cost ID to use. It is setup in Site Maintenance.

One odd thing I noticed on my setup, is that there is just the one Site Cost ID stup, and all sites - except our original one - use that Site Cost ID. The original site (MfgSys) has no Site Cost ID set.

But SSR works fine for us, so I don’t think that a missing Site CostID on the initial Site, is an issue (if you happen to see that too).