Unable to import function libraries in 2024.1 - you have no rights to import a library with custom code

This worked fine in 2023.2 . . . did something change in 2024.1? I can’t seem to move my libraries around anymore.

image

I don’t know if it is related or not, but I’m not able to install a CSF module with an error I’ve never seen before:

Current company has no rights to create or update extension records. It needs to have SDK License.

EDIT: I’ve got a support case open…

1 Like

I can’t remember which version they added these ‘Functions’ security groups, but they do have an effect on what you can do with Functions.

image

@aosemwengie1 do you have ALL the Function groups?
image

Yes I have every group.
image

Odd in my 2024.1 I can import it just fine.

1 Like

That gives me hope!

I hate to say it, but is there a chance this is a limitation in Cloud?

1 Like

If it is, its new in 2024.1 and a secret.

1 Like

Are you in a Shared cloud @aosemwengie1 ? I found some code that says if you are in a shared cloud environment they prevent this.

But I would assume you / most everyone is in dedicated tenancy now… no?

Public cloud.

It is my understanding that Public Cloud is dedicated tenancy equivalent you don’t share a DB with anyone else.

Right @klincecum ?

Can you remove yourself from these two groups and add yourself back in (then log out / log back in)

Also can you just go into a Library and Create a Code Function?

2 Likes

Ah ha! I even tried to do it in classic in case this is one of those browser ux bugs.

image

So looks like you don’t have Functions power developer rights. You need that to create / install custom code functions (that has always been the case)

But maybe they changed your permissions in this upgrade?

I suspect a ticket with the cloud team will get you back int shape.

Well, I did before, and I still do in all my other environments. Looks like they hosed something in 2024.1. Was hoping I could fix this without waiting for support to respond but I guess not.

2 Likes

Definitely a bug in 2024.1. In 2023.2 I can remove/readd the group all day long with no errrors.

They have a handful of MT clients left, but not many.

Yes, containerized app server instance, dedicated DB inside a shared SQL server.

3 Likes

That error is quite old, and should happen only in Shared cloud, so maybe your installation is not set as dedicated?

Its working fine right now in 2023.2 prod. Issue only exists in 2024.1 pilot. That tells me its a problem with the upgrade. There are other gsm problems since upgrading, for example, I can no longer access the kinetic menu options in menu maintenance either.

I seem to recall a similar issue with someone else.

I can’t remember if it was a bug, or if someone at cloud fat fingered a config file.