Updatable Dashboard Save from button click - how?

I’m hoping someone can point me in the right direction here. I want to trigger my updatable dashboard to save on a button click on the dashboard. What can I do?

Essentially, on a button click, I’d trigger a change to a field and then try to save it… my BPM would look for that “trigger” and then I could launch a BPM form. Then I can clean it all up when the form is submitted.

Back Story: I have an updateable dashboard that allows a person to update tasks assigned to them. I created a UD field called Notes_c that I have for the users to record their notes in. I have this idea that a button on the dashboard will launch a BPM form with a few fields… then I can use a BPM to take those fields and create a CRM Call and then format the info into a neat timestamped blurb of text on the end of the existing Notes_c field. In a nutshell, we are using the tasks as “goals” for our sales staff for specific customers. But I need to tie this to CRM somehow and that’s my idea. If I can get the BPM form to launch, I am confident I can take the inputs and format them appropriately to create a CRM call as well as update the Notes field.

Have you already tried searching for key word “SaveMenuTool”?
May be able to it from a custom button?

I’ll take a look. I appreciate the pointer.

So I’ve been able to edit an epiDataView field on the tracker in the dashboard assembly. But that doesn’t seem to recognize as an edit so when I hit save manually, nothing happens. If I type the same thing into the box that I am putting in there with my button click event, then hit save, it saves correctly. Is there something that I need to do when writing to the EDV so that it recognizes a change was made? I tried also setting RowMod to U in the same EDV. That didn’t work.

We can put this to bed for now. I’ve got it working … can’t say it was elegant. But I snuck around it and tricked it into working.

I’m trying to create a dashboard for updating tasks myself. What did you do to get that working? I’m trying to use BPM Update using either the Erp.EngWorkBench or Erp.Task business objects, but the uBAQ doesn’t want to update.

Didyou use BPM Update or Advanced BPM Update or what?

I am using the BPM Update. Are you trying the update in the BAQ Designer? If you try it there, it will show you the error that’s causing it not to Save. (usually)

So far I’m just working out of the BAQ designer until I can get that to work. I actually don’t receive any errors when I click update, the change just doesn’t “stick”. When I click “Get List”, the row returns without my update on the “Complete” checkbox. This is true when I try using “EngWorkBench” as the business object.

I tried using the business object for “Task” and it returned a message saying “a valid next milestone is required”. So the next thing I was going to do was to try and give it that.

Actually, I think I got it. I’m using the business object for Erp.Task and I’m now including “NextTaskID” and “NextTaskSeq” in my update and filling it in when applicable. Now I can just work to fill that in systematically.

Thank you for your help. I wasn’t even sure if what I was doing was possible until I saw your post!