Update BAQ and MtlQueue update error

I’ve added a UD field to MtlQueue and need to update it. I’ve created a update BAQ and chose the Erp.MaterialQueue Business Object Update Method UpdateExt.

I’ve chosen all the required field and set the custom field to allow updates. Any time I change it then try to Update I get the following:

Severity: Exception, Table: MtlQueue, Field: , RowID: ee2c0499-01d4-4e04-bdfc-26fba4e2c914, Text: Object reference not set to an instance of an object.
Query returned 1 row(s).

Any ideas what causes this error on update or any way to work around it?

Can you post screenshots of your update tabs to show the configurations you’ve made in the UBAQ?

Here’s the UBAQ update tabs. The MtlQueue_intCutTable_c is the custom field that I’m trying to update.

I don’t have any good records to test against right now; have you tried just including SysDate, SysTime, Plant, PartNum, Quantity, SysRowID and then re-running just to see if the context needs them in the resultset in order to process the update?

Good idea. I tried it and received the same error though.

I have seen this with the GetByID method and even when using BL Tester. I ended using GetRows but was able to in that situation. The error that GetRows gives when the whereClause is empty is the exact error you are getting. Guessing a bug.