Upgrade Error: Planning Contract For Multiple Bins Conversion

I do have a ticket open with Epicor support but just wondering if anyone else ran into this issue.

I am working on our upgrade from 10.2.200 to the latest version. I received the error below trying to do the upgrade in one swoop. I then setup a 11.1.100 server since that is what level the upgrade successfully made it to. The upgrade to 11.1.100 was successful but I get the same error trying to go from there to 11.2.100.

Information Upgrade Process Upgrade Process ERP11.1.200.0~ Executing: UpgradePlanningContractForMultipleBinsConversion.sql
Error Upgrade Process UpgradePlanningContractForMultipleBinsConversion.sql The INSERT statement conflicted with the FOREIGN KEY constraint “FK_PlanContractWhseBin_WhseBin”. The conflict occurred in database “KineticDB”, table “Erp.WhseBin”.
The statement has been terminated.
insert into erp.PlanContractWhseBin (Company, Cont

Any thoughts appreciated while I wait for the next communication with support.

Struggling to get past this error in our upgrade. I was able to upgrade to but then get the same error trying to go to the latest. Below is the response I received from support but it doesn’t seem to make any sense to me so not sure how to provide the information requested. Attempts to get more information from support have become frustrating. Any ideas?

Based on the error message, there appears to be a Warehouse missing contract and bin information. There is a data fix, but it requires the following parameters:

With the help of @Banderson we were able to find a contract with a bin number that didn’t exist. Solved that problem and now on to the next error.