Upgrade from 10.2.200 to 10.2.600 dashboards with external BAQ not working


Good Morning,

We upgraded from 10.2.200 to 10.2.600. Everything is working except for one major thing.

IT folks can run external baq dashboards and see results.

Users cannot; they open the dashboard and the grid is blank.

IT opens the dashboard, get the retrieving data, and data appears.

We had User log in on ITs machine and get the same results. Must be a security issue. Is there a new user config setting to allow them to se external BAQs.

It appears that when users are given security manager rights they can run the external BAQ. Don’t think we want to do that. Is there another security checkbox?

Is the query shared? Is it marked all companies? The other thing to I’d look at is if the external baq has a security ID associated with it

The BAQ looks ok to me.
Test Connection works.

Check user setup

what part? as what should I check in user setup?

I might try redeploying this dashboard as well

This is the server error. I’ll redeploy the dashboard, just to make sure.

Ice.Common.EpicorServerException: This query 'ETK-ExtDepotWIP' can only be modified by owner from owning company. ---> System.UnauthorizedAccessException: This query 'ETK-ExtDepotWIP' can only be modified by owner from owning company.
   at Ice.BO.BAQDesigner.Internal.CheckAccess.RowsChecker.Check(IReadOnlyCollection`1 rows) in C:\_Releases\ICE\UD10.2.600.8FW\Source\Server\Services\BO\BAQDesigner\Internal\CheckAccess\RowsChecker.cs:line 18
   at Ice.Services.BO.BAQDesignerSvc.UpdateQuerySecurityFilters(BAQDesignerTableset queryTableSet) in C:\_Releases\ICE\UD10.2.600.8FW\Source\Server\Services\BO\BAQDesigner\BAQDesigner.cs:line 826
   at Ice.Services.BO.BAQDesignerSvcFacade.UpdateQuerySecurityFilters(BAQDesignerTableset queryTableSet) in C:\_Releases\ICE\UD10.2.600.8FW\Source\Server\Services\BO\BAQDesigner\BAQDesignerSvcFacade.cs:line 824
   at Ice.Services.BO.DynamicQuerySvc.ExecuteInternal(DynamicQueryTableset queryDefinition, QueryExecutionTableset executionParams, Boolean updateExtSecurity) in C:\_Releases\ICE\RL10.2.600.0FW\Source\Server\Services\BO\DynamicQuery\DynamicQuery.Impl.cs:line 409
   at Ice.Services.BO.DynamicQuerySvc.Execute(DynamicQueryTableset queryDS, QueryExecutionTableset executionParams) in C:\_Releases\ICE\RL10.2.600.0FW\Source\Server\Services\BO\DynamicQuery\DynamicQuery.cs:line 111
   at Ice.Services.BO.DynamicQuerySvcFacade.Execute(DynamicQueryTableset queryDS, QueryExecutionTableset executionParams) in C:\_Releases\ICE\RL10.2.600.0FW\Source\Server\Services\BO\DynamicQuery\DynamicQuerySvcFacade.cs:line 162
   at SyncInvokeExecute(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   at Epicor.Hosting.OperationBoundInvoker.InnerInvoke(Object instance, Func`2 func) in C:\_Releases\ICE\UD10.2.600.8FW\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 59
   at Epicor.Hosting.OperationBoundInvoker.Invoke(Object instance, Func`2 func) in C:\_Releases\ICE\UD10.2.600.8FW\Source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 28
   --- End of inner exception stack trace ---

I assume you are the owner and in the owning company too? Maybe try switching owners, save, then set back to you

It works for me, though and anyone that is a security manager.

I’ll still give that a try.

Yeah that’s weird, I dunno man. Does it work in a different environment?

It works in 10.2.200 in test.

We have 2 servers we just upgraded to 10.2.600

I switched Author to the user and it worked for him and me. I am going to see if I can get the dashboard to pull for others.

I switched Author back to me and the BAQ doesn’t work for user. Its like the BAQ security is set to the level of the author…

Well that is certainly odd. Never seen that before!

Confirmed its a bug. If you use external BAQ’s .8 and .9 have the bug.


Yikes, good to know

We just upgraded to 10.2.600.9 Friday evening. We are experiencing the same issue this morning. @knash - work around to set to system admin or did you try to set a security group and would that work

We tried a few work arounds, but it is the Author in the BAQ that is the key, so groups didn’t work.

You can create excel data links to the views as a workaround.

Makes you wonder how these releases get through QA. Hopefully this gets logged as a test item moving forward :roll_eyes:


I am guessing this caused it. Added a feature

10.2.600.8 Tools and Technologies ICE-BAQ | BAQD Resolved Issue ERPS-140941 Query owner can pass ownership to another user

1 Like

I have reported this issue to support. PRB0226603 - if anyone want to add this reference to a support ticket.