Upgrade to 10.2.500.5 and custom web application

I upgraded our production server from 10.2.200.x to 10.2.500.x
we have several web based lookups that production uses all the time. testing one of the apps yields this error: There was no endpoint listening at http://my server/instance/Ice/BO/DynamicQuery.svc that could accept the message.

yet when I enter that url into a browser it returns:

DynamicQuerySvcFacade Service

You have created a service.

To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

I need to have this resolved prior to production resuming on Monday or else I will need to revert the server back to the original version of Epicor

Any lurkers out there have any ideas I can try

Any changes made to the config files? If you are using SSL is the certificate present and valid? If you’re using SSL you’ll need to make sure those bindings are present.

What’s the full endpoint address you’re trying? Without your server :wink: That doesn’t look valid (no v1/v2 etc) path.

@Chaddb using http so the certificate does not come into play for the app

@Aaron_Moreng the app is not using REST (I know I should convert it, but need the old wcf version to work for Monday)

thanks for taking the time to reply

You said it’s a WCF app. I assume it’s using SOAP then?

the site web.config files are pretty much the same except for some added stuff for .500

http protocol is enabled.

The error message also says: This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

yes, it is using SOAP - wondering if something changed between .200 and .500 :face_with_raised_eyebrow:

I assumed you were. We are not on .500 yet but it wouldn’t surprise me if they changed something in .500 that stops SOAP from working. Would force people to use REST :upside_down_face:

we have about half dozen apps. nearly all use dynamic queries. If I knew how to change from WCF to REST in the apps, then it would be pretty straight forward to fix them all. But I have like zero experience with REST

I won’t be much help on that front. But others here would be able to provide insight on that. Lots of developers here.

Did you reimport your references?

yes :frowning_face:
and VS2013 dev environment is not any more helpful than the error on the web server

Did you make sure you have an http / https binding enabled in your we config?

your post had me look at the web.config file and I noticed another remove scheme down lower in the file that removed http - commented that out and voila - back in business

Thanks everyone who offered ideas - I appreciate it!!