V8 Crystal Reports Database connections

Make sure when you set up the ODBC connection on the client in the Advanced
Tab you set the Default Isolation Level to READ UNCOMMITTED.

Also below is a KB from Epicor to adjust the ODBC Settings

Summary: ODBC Exceeded permissible number of connections. (8933)

Book: Support Solutions
Page: 7959MPS

PROBLEM: Invalid attribute in connection string, exceeded permissible
number of connections (8933).

This error occurs because the number of ODBC connections to the DB has
exceeded the number of ODBC connections the DB is set to allow.

RESOLUTION: Changes can be made from the Progress Explorer Tool, on the
Vantage server. Expand the database in question, until the MfgsysGroup
and ODBCGroup show. Check the Properties for each.

MfgSysGroup has:
Number of Servers: 12
Min Clients per Server: 4
Max Clients per Server: 4

ODBCGroup has:
Number of Servers: 20
Min Clients per Server: 1
Max Clients per Server: 2

The -n parameter is defined by the "maxclientsperserver" multiplied by
the numberofservers in the MfgSysGroup and ODBCGroup for each database.
In the example above, the -n is set to 48 users for the the MfgSysGroup
and 40 users for the ODBCGroup.

The Default Configuration properties screen must be a total of these as
follows:

MaxServers = numberofservers (MfgSysGroup) + numberofservers (ODBCGroup)
+ 1
So in this example Maxservers = 12 + 20 +1 or 33

Maxusers = maxclientsperserver x numberofservers (MfgSysGroup)
+ maxclientsperserver x numberofservers (ODBCGroup)
So in this example Maxusers = (4 x 12) + (2 x 20) or 88

Once these numbers are correct, stop the AppServers and the DB. When
they are stopped, restart the DB and the AppServers for the changes to
take effect.



Scott Litzau

-----Original Message-----
From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of
craigjenlau
Sent: Tuesday, August 28, 2007 9:44 AM
To: vantage@yahoogroups.com
Subject: [Vantage] V8 Crystal Reports Database connections

I am running into a problem with users not being able to run crystal
reports in version 8. It looks like it thinks we have used up all of
our database connections although we have plenty of licenses availabe.
Is there a parameter that needs to be changed somewhere? I think in
version 4 there was something you could change to prevent this from
happening.



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links
I am running into a problem with users not being able to run crystal
reports in version 8. It looks like it thinks we have used up all of
our database connections although we have plenty of licenses availabe.
Is there a parameter that needs to be changed somewhere? I think in
version 4 there was something you could change to prevent this from
happening.