Ver 5 Performance Problems

The .bi file has nothing to do with sort of problem. It used only to record the before image(hence the name) of records that are being changed.

The second run on the older client is faster because the data still resides in the system buffers, and hence is read from memory, not from disk. Again, I don't have source code, so I am only guessing, but this definitely sounds like a bug to me. Either there
is no suitable index, or the query has been poorly structured is not making the optimum use of the available indexes.

--
/* ============================================================== */

William E. Colls Tel 613 591 0079
PROComputer Systems Fax 613 591 3924
67 Willow Glen Dr www.procomsys.com
Kanata Ontario Canada PEG Member 1998051404

Specialists in Progress Software development since 1985
We went to Ver 5 one week ago, and performance is horrible! We have a
3.7 GB database, and 49 Vantage logins. Stats as follows:
Old ver 4 server New Ver 5 Server
-----------------------------------------------------------
Pentium III 500 Pentium III 500
392 MB RAM 768 MB RAM
RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K drives
10 extents (Vantage) 15 extents (Vantage)
Windows NT 4 Windows 2000 Server



One in particular is when you lookup a customer in Customer Tracker who
dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
out" the Invoices button ... in the mean time, the memory
pages-per-second goes WAY up!.
Durring the 3-5 minutes, the user's screen seems locked... until the
system finds out that there are no invoices.

On customers who have Invoices, it usually only takes 10 sec or so to
"grey out " the "Invoices" button.

I have been "tweeking" the buffers, changed the APW's , and nothing has
been even close to satisfactory!

I would like input on these two questions:

1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6 drives
to 3 mirrored drives, and spread the extents across them?

2. Could this be just a bug in the software which wasn't present in ver
4?



Thanks!

--
Britt Moelling
M&M Manufacturing Co.
For what it's worth:

I put two scsi hd controllers and two hd's (18 g each) in a redundant mirror scheme to keep speed up and also have some failsafe capability.

What o/s are you running on your clients?

Are you running hubbs or switches?


Rick Gors
MR/MMIS
Osco

Britt Moelling wrote:

> We went to Ver 5 one week ago, and performance is horrible! We have a
> 3.7 GB database, and 49 Vantage logins. Stats as follows:
> Old ver 4 server New Ver 5 Server
> -----------------------------------------------------------
> Pentium III 500 Pentium III 500
> 392 MB RAM 768 MB RAM
> RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K drives
> 10 extents (Vantage) 15 extents (Vantage)
> Windows NT 4 Windows 2000 Server
>
> One in particular is when you lookup a customer in Customer Tracker who
> dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
> out" the Invoices button ... in the mean time, the memory
> pages-per-second goes WAY up!.
> Durring the 3-5 minutes, the user's screen seems locked... until the
> system finds out that there are no invoices.
>
> On customers who have Invoices, it usually only takes 10 sec or so to
> "grey out " the "Invoices" button.
>
> I have been "tweeking" the buffers, changed the APW's , and nothing has
> been even close to satisfactory!
>
> I would like input on these two questions:
>
> 1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6 drives
> to 3 mirrored drives, and spread the extents across them?
>
> 2. Could this be just a bug in the software which wasn't present in ver
> 4?
>
> Thanks!
>
> --
> Britt Moelling
> M&M Manufacturing Co.
>
> To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please go to: http://groups.yahoo.com/group/vantage/files/. Note: You must have already linked your email address to a yahoo id to enable access.
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/


[Non-text portions of this message have been removed]
Rick.

Questions:
1. How big is your database?
2. Do you have two Logical Drives (C & D)?
3. How do you have your NT swap files configured?
4. How do you have your Vantage data configured (multi-extents?
location of BI?)
5. Is your Progress & Vantage data on the same drive?
6. How is your performance?

We are running Windows 95 & 98, and we do have switches. I usually turn
off the auto-sensing on the workstations.

Thanks!
Britt Moelling


Rick Gors wrote:

> For what it's worth:
>
> I put two scsi hd controllers and two hd's (18 g each) in a redundant
> mirror scheme to keep speed up and also have some failsafe capability.
>
> What o/s are you running on your clients?
>
> Are you running hubbs or switches?
>
>
> Rick Gors
> MR/MMIS
> Osco
>
> Britt Moelling wrote:
>
> > We went to Ver 5 one week ago, and performance is horrible! We
> have a
> > 3.7 GB database, and 49 Vantage logins. Stats as follows:
> > Old ver 4 server New Ver 5 Server
> > -----------------------------------------------------------
> > Pentium III 500 Pentium III 500
> > 392 MB RAM 768 MB RAM
> > RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K
> drives
> > 10 extents (Vantage) 15 extents (Vantage)
> > Windows NT 4 Windows 2000 Server
> >
> > One in particular is when you lookup a customer in Customer Tracker
> who
> > dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
>
> > out" the Invoices button ... in the mean time, the memory
> > pages-per-second goes WAY up!.
> > Durring the 3-5 minutes, the user's screen seems locked... until
> the
> > system finds out that there are no invoices.
> >
> > On customers who have Invoices, it usually only takes 10 sec or so
> to
> > "grey out " the "Invoices" button.
> >
> > I have been "tweeking" the buffers, changed the APW's , and nothing
> has
> > been even close to satisfactory!
> >
> > I would like input on these two questions:
> >
> > 1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6
> drives
> > to 3 mirrored drives, and spread the extents across them?
> >
> > 2. Could this be just a bug in the software which wasn't present in
> ver
> > 4?
> >
> > Thanks!
> >
> > --
> > Britt Moelling
> > M&M Manufacturing Co.
> >
> > To access the Files Section of our Yahoo!Group for Report Builder
> and Crystal Reports and other 'goodies', please go to:
> http://groups.yahoo.com/group/vantage/files/. Note: You must have
> already linked your email address to a yahoo id to enable access.
> >
> > Your use of Yahoo! Groups is subject to
> http://docs.yahoo.com/info/terms/
>
>
> [Non-text portions of this message have been removed]
>
>
> Yahoo! Groups Sponsor
[Click Here to Find Software Faster]
Click Here to Find Software Faster

>
> To access the Files Section of our Yahoo!Group for Report Builder and
> Crystal Reports and other 'goodies', please go to:
> http://groups.yahoo.com/group/vantage/files/. Note: You must have
> already linked your email address to a yahoo id to enable access.
>
> Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

--
Britt Moelling
M&M Manufacturing Co.



[Non-text portions of this message have been removed]
Britt:

I'm on vantage 4.0, NT 4.0, sp 6a

1. 190 MB
2. Yes C: small/FAT D: big/NTFS-epicor dir
3. NT Virtual memeory - C: 500 mb initial size - 550 mb max
4. Multi-extents? Do you mean multi-volume? Yes-this is from Prgress.
B1and all other vantage files in epicor\vantage\db dir
5. Yes.
6. Acceptable - after moving all win95 up to 98.

I found no difference screwing with the settings on my 3com 3c905 NICs (auto or forced half duplex). If your switches allow full duplex I'd force that and try it.

Also I changed the settings in the vanatge.pf and startup.pf files as follows:

vantage.pf

-Mm 16384
-mmax 4000 (same)
-Bt 3000
all others=same


startup.pf

-B 30000
-n 30 (15 actual users)
added:
-Mm 16384
-Mn 20
-Ma 1
-Mi 1



Also, you could try changing the Vantage.vtg (right click vantage icon, choose edit):

on the ConnectOptions line use the server ip address instead of the name (server1 becomes 100.100.100.100. This would help at startup at client a bit.

Any questions - email back or call 248/852-7310

Rick




Britt Moelling wrote:

> Rick.
>
> Questions:
> 1. How big is your database?
> 2. Do you have two Logical Drives (C & D)?
> 3. How do you have your NT swap files configured?
> 4. How do you have your Vantage data configured (multi-extents?
> location of BI?)
> 5. Is your Progress & Vantage data on the same drive?
> 6. How is your performance?
>
> We are running Windows 95 & 98, and we do have switches. I usually turn
> off the auto-sensing on the workstations.
>
> Thanks!
> Britt Moelling
>
> Rick Gors wrote:
>
> > For what it's worth:
> >
> > I put two scsi hd controllers and two hd's (18 g each) in a redundant
> > mirror scheme to keep speed up and also have some failsafe capability.
> >
> > What o/s are you running on your clients?
> >
> > Are you running hubbs or switches?
> >
> >
> > Rick Gors
> > MR/MMIS
> > Osco
> >
> > Britt Moelling wrote:
> >
> > > We went to Ver 5 one week ago, and performance is horrible! We
> > have a
> > > 3.7 GB database, and 49 Vantage logins. Stats as follows:
> > > Old ver 4 server New Ver 5 Server
> > > -----------------------------------------------------------
> > > Pentium III 500 Pentium III 500
> > > 392 MB RAM 768 MB RAM
> > > RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K
> > drives
> > > 10 extents (Vantage) 15 extents (Vantage)
> > > Windows NT 4 Windows 2000 Server
> > >
> > > One in particular is when you lookup a customer in Customer Tracker
> > who
> > > dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
> >
> > > out" the Invoices button ... in the mean time, the memory
> > > pages-per-second goes WAY up!.
> > > Durring the 3-5 minutes, the user's screen seems locked... until
> > the
> > > system finds out that there are no invoices.
> > >
> > > On customers who have Invoices, it usually only takes 10 sec or so
> > to
> > > "grey out " the "Invoices" button.
> > >
> > > I have been "tweeking" the buffers, changed the APW's , and nothing
> > has
> > > been even close to satisfactory!
> > >
> > > I would like input on these two questions:
> > >
> > > 1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6
> > drives
> > > to 3 mirrored drives, and spread the extents across them?
> > >
> > > 2. Could this be just a bug in the software which wasn't present in
> > ver
> > > 4?
> > >
> > > Thanks!
> > >
> > > --
> > > Britt Moelling
> > > M&M Manufacturing Co.
> > >
> > > To access the Files Section of our Yahoo!Group for Report Builder
> > and Crystal Reports and other 'goodies', please go to:
> > http://groups.yahoo.com/group/vantage/files/. Note: You must have
> > already linked your email address to a yahoo id to enable access.
> > >
> > > Your use of Yahoo! Groups is subject to
> > http://docs.yahoo.com/info/terms/
> >
> >
> > [Non-text portions of this message have been removed]
> >
> >
> > Yahoo! Groups Sponsor
> [Click Here to Find Software Faster]
> Click Here to Find Software Faster
>
> >
> > To access the Files Section of our Yahoo!Group for Report Builder and
> > Crystal Reports and other 'goodies', please go to:
> > http://groups.yahoo.com/group/vantage/files/. Note: You must have
> > already linked your email address to a yahoo id to enable access.
> >
> > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
>
> --
> Britt Moelling
> M&M Manufacturing Co.
>
> [Non-text portions of this message have been removed]
>
> To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please go to: http://groups.yahoo.com/group/vantage/files/. Note: You must have already linked your email address to a yahoo id to enable access.
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/


[Non-text portions of this message have been removed]
With regard to the long wait to determine there are no invoices:

When you ask for a customer who has invoices, does the time required for the search vary according to how recent the the customers last invoice is? In other words, if the most recent invoice is within the last 4-6 weeks is it noticeably faster than if the
most recent invoice is a year ago? If this is true I would suspect an index problem. I'm guessing here, but either there is no index by customer, or the query has is badly structured, and Progress has chosen the wrong index. This would be a bug.

Britt Moelling wrote:

> We went to Ver 5 one week ago, and performance is horrible! We have a
> 3.7 GB database, and 49 Vantage logins. Stats as follows:
> Old ver 4 server New Ver 5 Server
> -----------------------------------------------------------
> Pentium III 500 Pentium III 500
> 392 MB RAM 768 MB RAM
> RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K drives
> 10 extents (Vantage) 15 extents (Vantage)
> Windows NT 4 Windows 2000 Server
>
> One in particular is when you lookup a customer in Customer Tracker who
> dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
> out" the Invoices button ... in the mean time, the memory
> pages-per-second goes WAY up!.
> Durring the 3-5 minutes, the user's screen seems locked... until the
> system finds out that there are no invoices.
>
> On customers who have Invoices, it usually only takes 10 sec or so to
> "grey out " the "Invoices" button.
>
> I have been "tweeking" the buffers, changed the APW's , and nothing has
> been even close to satisfactory!
>
> I would like input on these two questions:
>
> 1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6 drives
> to 3 mirrored drives, and spread the extents across them?
>
> 2. Could this be just a bug in the software which wasn't present in ver
> 4?
>
> Thanks!
>
> --
> Britt Moelling
> M&M Manufacturing Co.
>
> To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please go to: http://groups.yahoo.com/group/vantage/files/. Note: You must have already linked your email address to a yahoo id to enable access.
>
> Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/

--
/* ============================================================== */

William E. Colls Tel 613 591 0079
PROComputer Systems Fax 613 591 3924
67 Willow Glen Dr www.procomsys.com
Kanata Ontario Canada PEG Member 1998051404

Specialists in Progress Software development since 1985
I know there was a thread on this earlier, but I am just horrified with the
outcome of my test install for release 5.0 I installed release 5 last week
for test purposes only. I installed the client on 2 PC's; Mine and another
Manager. Since doing the install, regardless of which version we use (5 for
testing or 4 in live mode) I am not able to run word or excel at the same
time. This is just for the 2 machines with the test software. Both are
Pentium III with 128MB of RAM, It's AMAZING. I launch an excel spreadsheet
and it sits....If I alt tab to Vantage, close it down...and only then will
the Excel application run. I uninstalled the Progress client (9.1A) and
still have the same problem. I re-installed the Vantage client version 4
and all is back to normal. Do any of you have a fix for this? I am
assuming my best bet is to stay on version 4.0, as I am not getting warm and
fuzzy feelings about 5.
Just my 2 cents, We have seen a slight reduction in performance, but have
experienced no issues with Microsoft Office products. I ran into a similar
issue during my test install with excel and word. However, once I did the
full install there have been no significant issues. Actually, my users seem
pretty pleased with the new version.

Shirley Graver
(End User)
Sys Admin
Rubber associates Inc.
Cleveland/Akron



[Non-text portions of this message have been removed]
William
I did a test on a customer who's last invoice was July of last year.
The first time we went into customer tracker for them it took 1 1/2
minutes. We then immediately went into the same customer again, and it
only took a few seconds (3-4 sec).
On a customer who have no invoices it takes about 5 minutes each
time.... I'm thinking that since the first run, no invoices were found,
there were no records in the BI file, and so a sequential search is
performed.


William Colls wrote:

> With regard to the long wait to determine there are no invoices:
>
> When you ask for a customer who has invoices, does the time required
> for the search vary according to how recent the the customers last
> invoice is? In other words, if the most recent invoice is within the
> last 4-6 weeks is it noticeably faster than if the
> most recent invoice is a year ago? If this is true I would suspect an
> index problem. I'm guessing here, but either there is no index by
> customer, or the query has is badly structured, and Progress has
> chosen the wrong index. This would be a bug.
>
> Britt Moelling wrote:
>
> > We went to Ver 5 one week ago, and performance is horrible! We
> have a
> > 3.7 GB database, and 49 Vantage logins. Stats as follows:
> > Old ver 4 server New Ver 5 Server
> > -----------------------------------------------------------
> > Pentium III 500 Pentium III 500
> > 392 MB RAM 768 MB RAM
> > RAID 1 (2 7200 rpm drives) RAID 0/1 array using 6 10K
> drives
> > 10 extents (Vantage) 15 extents (Vantage)
> > Windows NT 4 Windows 2000 Server
> >
> > One in particular is when you lookup a customer in Customer Tracker
> who
> > dosen't have any Invoices, it takes 3-5 minutes for Vantage to "grey
>
> > out" the Invoices button ... in the mean time, the memory
> > pages-per-second goes WAY up!.
> > Durring the 3-5 minutes, the user's screen seems locked... until
> the
> > system finds out that there are no invoices.
> >
> > On customers who have Invoices, it usually only takes 10 sec or so
> to
> > "grey out " the "Invoices" button.
> >
> > I have been "tweeking" the buffers, changed the APW's , and nothing
> has
> > been even close to satisfactory!
> >
> > I would like input on these two questions:
> >
> > 1. Is RAID 0/1 slower than mirroring? Should I reconfigure the 6
> drives
> > to 3 mirrored drives, and spread the extents across them?
> >
> > 2. Could this be just a bug in the software which wasn't present in
> ver
> > 4?
> >
> > Thanks!
> >
> > --
> > Britt Moelling
> > M&M Manufacturing Co.
> >
> > To access the Files Section of our Yahoo!Group for Report Builder
> and Crystal Reports and other 'goodies', please go to:
> http://groups.yahoo.com/group/vantage/files/. Note: You must have
> already linked your email address to a yahoo id to enable access.
> >
> > Your use of Yahoo! Groups is subject to
> http://docs.yahoo.com/info/terms/
>
> --
> /* ============================================================== */
>
> William E. Colls Tel 613 591 0079
> PROComputer Systems Fax 613 591 3924
> 67 Willow Glen Dr www.procomsys.com
> Kanata Ontario Canada PEG Member 1998051404
>
> Specialists in Progress Software development since 1985
>
>
>
> Yahoo! Groups Sponsor
[Click Here to Find Software Faster]
Click Here to Find Software Faster

>
> To access the Files Section of our Yahoo!Group for Report Builder and
> Crystal Reports and other 'goodies', please go to:
> http://groups.yahoo.com/group/vantage/files/. Note: You must have
> already linked your email address to a yahoo id to enable access.
>
> Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.

--
Britt Moelling
M&M Manufacturing Co.



[Non-text portions of this message have been removed]