Website Widget Control - Inject params into URL from views

I had{KEV_Get_Assemblies_0_0.Calculated_AssemblyName}

It went to

Huh. On 2023.1.5?

2023.1 naked.

This is a cloud environment, but a test one that is behind. I can upgrade tonight and see
if there is a regression. (As soon as I can get @josecgomez out of it lol)

Out of curiosity, did you type your view.column correctly? I believe a typo might just print it out like yours is.

Also, if you are creating your view later on, you may have to click reload on the widget,
because the view does not exist when the widget tries to load.

In this case, the full placeholder I’m using is {ReportParam.Jobs} on the Job Traveler print app. The autocomplete helpfully suggests it in this case.


Does the web widget reactively update the URL when placeholder values change? I also tried using property-set on the ‘url’ property of the widget, but this doesn’t seem to work.

[edit]This was in Chrome. Just tested in Kinetic client with same result.

In this case upon first load, ReportParam.Jobs would be empty, but I would assume that the web widget would reactively update the URL once a job is filtered. No?

That has been my experience.

Also, clicking reload on the widget has no effect on the URL.

Go ahead and add a textbox field to that screen and bind it to ReportParam.Jobs

See if that updates as expected.

Hey! I was watching that!

I’m sensing a pattern here.

Doh! I keep screwing up my redaction. Safety first! :safety_vest:

Well What the …

I’m not sure why it’s not working.

Just for giggles, try marking it as a key field on the widget.

@fvodden try this widget. I replicated your issue with the widget that’s in the Toolbox.


That’s the widget I used. I didn’t know there was one in the toolbox :rofl:

I honestly cannot tell the difference between the 2. I just remembered that one in the “Widgets” one instead of the “Components” and thought I’d try it.


Well, look at that. I didn’t even think to look under the Widgets tab. It is now working as expected. The toolbox one also has a typo “WebSite Widgit Control”.

Thanks for your help!

I think pretty much everything I’ve done as demo, was done using similar methods… No way I could just build this in pure Kinetic… more of a round-robin REST :slight_smile: