10.1 Importing parts

I’m in the process of (trying) to import parts into my Epicor 10.1 environment (1st attempt). I’m using a subset of something like 50 parts. I am receiving the following error.

Part Table: Part Msg: Default Warehouse for the current site not setup.

Only thing is, I’ ve checked both of the site programs and the default warehouses information is there. I’ve checked company config. Where else is there to look? Or is there something else I need to check and the error message is misleading? Any help appreciated.
Thank you.

weird behavior. I restarted the DMT - found that there was an update available, loaded it and restarted again. I tried updating again and it worked. who am I to question?
Back at 'er.

1 Like

Have another question on Importing Parts.
I have an export/import ready to go on the Part Revision Table. Unfortunately it appears as though it requires 2 fields that are not available in Vantage “BasePartNum” and “BaseRevisionNum”.

I’m wondering (for those of you that have imported Parts before, Can you import Part Revisions, or do you have to import all new parts and revisions through the Engineering Workbench? Or maybe some combination thereof?

Can someone help me? I’m stuck and looking for some guidance.


I haven’t imported part rev’s before, however I’m looking in our system (10.1.600.5) and the BasePartNum and BaseRevisionNum are both empty strings. I don’t have anything that has anything in those fields. I imagine you can just add those headers and “” in the CSV and it will probably let you complete the import.

Let us know if that works.


I’ve never had to use these fields. Is the DMT calling for them if you
don’t include them? Complaining that they are blank if you do?

Yes, you should be able to import all your parts, revisions, BOMs, etc. via

If you include a column with no info (blank), the DMT may tell you the
field is missing because it’s trying to look up acode. Usually you can just
delete the column. Or if you have some rows with these fields present,
delete the column from the reprocess file.


I looked in DMT, and it doesn’t look like they are required (like Joe says) Where are you seeing that it’s required @jhenslee?

Just to add to this thread, all of our BasePartNum and BaseRevisionNum are blank as well. We currently have over 9800+ records in the partrev table.

Did you get it figured out?

BasePartNum and BasePartRev are related to the Product Configurator that created that revision. You’ll see the same fields in OrderDtl (and maybe now PODetail).

Mark W.

Yes I believe I did figure it out. I started dropping all of the unnecessary fields (those that don’t have data in them) and just focus on those with data and not just include something because the field names are the same. Seems to have worked.

Thanks to all who replied

The error came back again as I was uploading to my pilot database. I did some reviewing of the template field descriptions in the DMT and the base part number and revision number are associated to the product configurator - which we do not have implemented. So I added the configured column to the import and set all of the values to False (0) and this seems to have addressed most of the issues. The file is loading again and the errors have quieted down considerably. Will update everyone with my final findings. Thanks.

Crud. Spoke too soon. Did not correct the issue. Still testing.

Thanks for the suggestion. I have tried importing the files with both of the columns not defined, defined but blank and also defined with the part number and revision number copied from the part number and revision number of the part rev record. I’m still getting invalid base revision errors (all over the place). it doesn’t seem to be consistent.

Personally, I believe I have stammered onto a bug in the DMT tool. I had a huge part revision file that I split into 10 files and ran the import on each. I recorded the total number of records in each file and the number of records completed. I then split each of those import files into 10 sub files, imported them and also recorded those numbers. “technically” I should see the same number of records for successful completion and errors for the sub files as I did for the main files? Correct? Well I don’t. How can the same file(s) produce different results?

This is so frustrating! Luckily I am working with someone from tech support who is a DMT specialist and they appear to be as baffled as I am.

Guess What??? We think we may have found or uncovered either a bug in the DMT tool or an issue with the DMT tool and our data which is causing the DMT to freak out and (hopefully) send a potentially bogus message. Epicor has been able to replicate my error and is working on identifying the issue so I can complete my import!! YAHOO!

Yahoo? (Only the older people are going to remember this one)

can u tell me to what DMT version you updated that resolved the “invalid base revision” error dmt was giving ?

The Part Revision Import in DMT for Epicor 10 versions to contains an issue which will display an invalid base revision error on rows following an alt method row. This issue was fixed in the September release of DMT (version

1 Like