[5.2] Crystal Reports run time

Todd, I've tried a number of things, but nothing seems to consistently help.
You're right in that there is something that has to wake up the
"_sqlsrv2.exe" process. I thought I was on to something on Monday when I
started a Vantage session on my workstation first, and the reports then ran
in seconds. So today I again started Vantage, ran the reports and again
they ran in seconds. But I reran the report about an hour later (Vantage
still running), and the report run time takes several minutes again. The
"_sqlsrv2.exe" process is the key. Sometimes it uses 60-90% processor time
on the server, and when the report takes minutes, the process uses less than
6%. When it uses 6%, it is still the only process consuming any CPU time.

Norm

-----Original Message-----
From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]On Behalf
Of Todd Caughey
Sent: Thursday, July 21, 2005 3:33 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage][5.2] Crystal Reports run time


Two immediate (though probably not solid) thoughts...
1. Sometime before running it try opening File Explorer and browsing to the
database folder. Perhaps the network connection to the mapped drive needs
to be "woke up". See if the report then consistantly runs faster the first
time.
2. Some process on the server related to ODBC maybe needs to "fire up" and
grab some memory space or swap back into memory from disk swap file? Then
for the next run it is ready to go? Maybe do something else to tickle the
ODBC process on the server (like above for network - maybe run a very simple
report to dump the Company table) and then run the report to see if it
always runs faster after that.

A couple things to try to isolate the cause. Probably other things too.

-Todd C.

-----Original Message-----
From: Norm Watkins [mailto:nwatkins@...]
Sent: Thursday, July 21, 2005 3:01 PM
To: Vantage@Yahoogroups. Com
Subject: [Vantage][5.2] Crystal Reports run time


I'm on Vantage 5.2, Progress 9.1D08, CR 8.5 (with patches installed).

Can somebody explain why the run time for the same report (with similar
amounts of data) vary in run time on the same workstation. I usually leave
my workstation (W2000Pro) running and connected to the server (W2000Server)
overnight, and run the report every morning. Some mornings it runs in a few
seconds, and other times it takes more than 3 minutes. At the time I run
the report, I check the server for running processes, and CPU time is
usually 1-4%. The process that consumes CPU time when I run the report is
"_sqlsrv2.exe". When the report runs in a few seconds, this process uses
all available CPU time; when it runs slow, it is only using about 3-4% CPU
time, and the remainder CPU time is "System Idle Process". Once I run the
report, I can run it again immediately, and the run time is again just a few
seconds.

Checking the ODBC configuration and when running a "test connect",
connection is established almost immediately.

Thanks for any help.

Norm Watkins
Engineering Manager
ELECPAC
Phone: 847-639-2307



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links



_____

YAHOO! GROUPS LINKS



* Visit your group " vantage <http://groups.yahoo.com/group/vantage> " on
the web.


* To unsubscribe from this group, send an email to:
vantage-unsubscribe@yahoogroups.com
<mailto:vantage-unsubscribe@yahoogroups.com?subject=Unsubscribe>


* Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
<http://docs.yahoo.com/info/terms/> .


_____




[Non-text portions of this message have been removed]



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links
I'm on Vantage 5.2, Progress 9.1D08, CR 8.5 (with patches installed).

Can somebody explain why the run time for the same report (with similar
amounts of data) vary in run time on the same workstation. I usually leave
my workstation (W2000Pro) running and connected to the server (W2000Server)
overnight, and run the report every morning. Some mornings it runs in a few
seconds, and other times it takes more than 3 minutes. At the time I run
the report, I check the server for running processes, and CPU time is
usually 1-4%. The process that consumes CPU time when I run the report is
"_sqlsrv2.exe". When the report runs in a few seconds, this process uses
all available CPU time; when it runs slow, it is only using about 3-4% CPU
time, and the remainder CPU time is "System Idle Process". Once I run the
report, I can run it again immediately, and the run time is again just a few
seconds.

Checking the ODBC configuration and when running a "test connect",
connection is established almost immediately.

Thanks for any help.

Norm Watkins
Engineering Manager
ELECPAC
Phone: 847-639-2307
Two immediate (though probably not solid) thoughts...
1. Sometime before running it try opening File Explorer and browsing to the database folder. Perhaps the network connection to the mapped drive needs to be "woke up". See if the report then consistantly runs faster the first time.
2. Some process on the server related to ODBC maybe needs to "fire up" and grab some memory space or swap back into memory from disk swap file? Then for the next run it is ready to go? Maybe do something else to tickle the ODBC process on the server (like above for network - maybe run a very simple report to dump the Company table) and then run the report to see if it always runs faster after that.

A couple things to try to isolate the cause. Probably other things too.

-Todd C.

-----Original Message-----
From: Norm Watkins [mailto:nwatkins@...]
Sent: Thursday, July 21, 2005 3:01 PM
To: Vantage@Yahoogroups. Com
Subject: [Vantage][5.2] Crystal Reports run time


I'm on Vantage 5.2, Progress 9.1D08, CR 8.5 (with patches installed).

Can somebody explain why the run time for the same report (with similar
amounts of data) vary in run time on the same workstation. I usually leave
my workstation (W2000Pro) running and connected to the server (W2000Server)
overnight, and run the report every morning. Some mornings it runs in a few
seconds, and other times it takes more than 3 minutes. At the time I run
the report, I check the server for running processes, and CPU time is
usually 1-4%. The process that consumes CPU time when I run the report is
"_sqlsrv2.exe". When the report runs in a few seconds, this process uses
all available CPU time; when it runs slow, it is only using about 3-4% CPU
time, and the remainder CPU time is "System Idle Process". Once I run the
report, I can run it again immediately, and the run time is again just a few
seconds.

Checking the ODBC configuration and when running a "test connect",
connection is established almost immediately.

Thanks for any help.

Norm Watkins
Engineering Manager
ELECPAC
Phone: 847-639-2307



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and Crystal Reports and other 'goodies', please goto: http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto: http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto: http://groups.yahoo.com/group/vantage/links



_____

YAHOO! GROUPS LINKS



* Visit your group " vantage <http://groups.yahoo.com/group/vantage> " on the web.


* To unsubscribe from this group, send an email to:
vantage-unsubscribe@yahoogroups.com <mailto:vantage-unsubscribe@yahoogroups.com?subject=Unsubscribe>


* Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service <http://docs.yahoo.com/info/terms/> .


_____




[Non-text portions of this message have been removed]
How about antivirus also.

Frank Zeigafuse
Innovative Office Products
General Manager
Direct Phone: 610-559-6369
Email: fzeigafuse@...

Visit www.one.org to see how the world can be changed one person at a time.



-----Original Message-----
From: Todd Caughey [mailto:caugheyt@...]
Sent: Thursday, July 21, 2005 4:33 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage][5.2] Crystal Reports run time


Two immediate (though probably not solid) thoughts...
1. Sometime before running it try opening File Explorer and browsing to the
database folder. Perhaps the network connection to the mapped drive needs
to be "woke up". See if the report then consistantly runs faster the first
time. 2. Some process on the server related to ODBC maybe needs to "fire up"
and grab some memory space or swap back into memory from disk swap file?
Then for the next run it is ready to go? Maybe do something else to tickle
the ODBC process on the server (like above for network - maybe run a very
simple report to dump the Company table) and then run the report to see if
it always runs faster after that.

A couple things to try to isolate the cause. Probably other things too.

-Todd C.

-----Original Message-----
From: Norm Watkins [mailto:nwatkins@...]
Sent: Thursday, July 21, 2005 3:01 PM
To: Vantage@Yahoogroups. Com
Subject: [Vantage][5.2] Crystal Reports run time


I'm on Vantage 5.2, Progress 9.1D08, CR 8.5 (with patches installed).

Can somebody explain why the run time for the same report (with similar
amounts of data) vary in run time on the same workstation. I usually leave
my workstation (W2000Pro) running and connected to the server (W2000Server)
overnight, and run the report every morning. Some mornings it runs in a few
seconds, and other times it takes more than 3 minutes. At the time I run
the report, I check the server for running processes, and CPU time is
usually 1-4%. The process that consumes CPU time when I run the report is
"_sqlsrv2.exe". When the report runs in a few seconds, this process uses
all available CPU time; when it runs slow, it is only using about 3-4% CPU
time, and the remainder CPU time is "System Idle Process". Once I run the
report, I can run it again immediately, and the run time is again just a few
seconds.

Checking the ODBC configuration and when running a "test connect",
connection is established almost immediately.

Thanks for any help.

Norm Watkins
Engineering Manager
ELECPAC
Phone: 847-639-2307



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links



_____

YAHOO! GROUPS LINKS



* Visit your group " vantage <http://groups.yahoo.com/group/vantage>
" on the web.


* To unsubscribe from this group, send an email to:
vantage-unsubscribe@yahoogroups.com
<mailto:vantage-unsubscribe@yahoogroups.com?subject=Unsubscribe>


* Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
<http://docs.yahoo.com/info/terms/> .


_____




[Non-text portions of this message have been removed]



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links