Activate buttons on MES


All the functions in MES are greyed out. All I can do is Clock in/out, start/end Production , Indirect, Setup and Rework activity. See job tracker and part tracker.

None of the functions under service. production, material, package control, shipping/Receiving and Supervisor are activate. How can I fix this. The employee setup screen looks as follows:

They are using the generic shop login for MES and that user has access to enter material transactions and even adjust quantities on Epicor Client.


You’ll need to start an activity.

Has anyone made changes to your Security Maintenance? ie. Security groups, Menu’s etc?

@bwhite No Changes were made in the security maintenance.

@klincecum Even after I start Activity, those buttons are greyed out

Check MES/Handheld Menu Security - you can set options by type of employee or turn options off all together. If you are using the classic MES version, you can also manage that by a form customization.

Can you explain in detail how can this be done. We are using classic MES version

What I have done in some of our companies for functions we do not want anyone to use, is turned off the option completely by unchecking all of the check boxes. Whatever the employee roles are on the employee record directly line up with the roles in the menu options.

Depending on what version you are in you may or may not have everything you see in the menu tree. What I have run into on our system is that the employee logs in with a user account, if there’s an actual menu option of the same item, i.e. job receipt to inventory = mfg receipt, then the user has to have access, the employee record has to be flagged to line up with the mfg receipt and then it works.

Something else to note is that mobile warehouse by default does not honor these settings, you have to turn it on from the device and then setup the employee roles.

Thanks, for pointing out to the menu. For some reason, I don’t have see the MES on my menu tree. i am logged in with system admin access. The version we are using is 10.1.500.8. What can i do to get the MES added under the Menu groups

It sounds like then it may not be supported in your version. I know that we had the MES options in 10.2. Mobile Warehouse was not an option in that version. We’re currently in 2022.2 so that is what you are seeing here.

One thing to try then would be to “hide” or make the fields in MES not active. You can use customizations in MES similar to how you do in the desktop client. Depending on where the custom is, there’s a trick to getting it to work. I’m not as familiar going this route. If you are system admin and have customization permissions, then you can log into MES. Before you clock in as an employee, right click anywhere along the outside edge and you will find the developer mode option.

@N_Shah The Handheld/MES Menu Security Maintenance form is under Main>System Setup>Security Maintenance.

Thanks @Rookie . What version of Epicor are you using. We are at 10.1.500.8. We don’t have Handheld/MES Menu Security Maintenance option under system setup.


Suggest you add the version to your profile.