Application error (7224)

We are getting some users that are getting the application error below. Would these errors be widespread or why would it be limited to certain departments? Does it require a restart of the appservers or what can those users do? They are getting it about 2 times a day.

“tried to call a method in an invalid procedure (7224).”

Do you know what these users are doing when they get the error? Is there a particular function or menu item that they’re using? Also, this page seems to give a little information on the error.

I believe it’s happening more widespread and not associated to a particular process. What is usually done to resolve the issue?

I can’t say since I’ve never personally ran into this problem, but the link below has a lot of options people have tried for this particular problem. It looks like most of them revolve around dealing with network problems (dropped packets, etc.) causing the error. One particular possible solution would be to check off the Network Compression setting for users.

What does ‘Network Compression’ do? Do you think it will help resolve the (7224) application error?

Network compression allows a trade of an increase in CPU utilization on the Epicor server/client machines for a decrease in overall network traffic as it compresses/decompresses the traffic to/from the clients.

In a LAN environment, it is almost always better to not use network compression as the trade-off usually results in a decrease in overall performance for the end user.

In a WAN environment, it is almost always better to use network compression (everything else being equal) as it usually results in an increase in overall performance for the end user.

You can test the performance impact of a single user using the Network Compression flag within the Performance and Diagnostic Tool > Network Diagnostics test.

We always get this when the network drops. Even just a packet or 2…I hear E10 is more forgiving on the reconnect.

1 Like

Did you just ignore the error and log back in? Did you do anything to resolve the issue?

right now we just click reconnect or close and log back in.

Did you try or look into enabling ‘network compression’ if that helped? We are having our network team look to see if they are seeing any dropped packets or network issue but it doesn’t seem like it’s an Epicor issue.