Automation studio - where is it?

So we purchased automation studio but I can’t figure out how to access it. I got an emailed invite to “Epicor integration tenant” and I accepted it but the page just says that I have accepted the invite and I can close this window, it doesn’t actually log me into anything. I asked support what the url would be to access Automation Studio and they said, “Automation studio required a billable onboarding process”. Really??? I thought this was supposed to be simple to set up? So confused. Anyone else been through this and can advise how to get going? Of course I did reach out to our CAM but no response yet.

It’s accessed from within the Kinetic interface. There is a little initial setup including the site setup “onboarding” by Epicor/Workato team, but it didn’t cost me anything that I recall, they just need to do it so you can connect to it. Then you have to get your Kinetic client connected to it - Go to to get started…

If I can find the document I used I’ll post it.

Thanks for responding - who did you contact for the initial setup, do you recall?

Once out license request went through, we got an email from Epicor about setting up an Epicor IDP user on that service. After that, we worked with - but I’m pretty sure I put in a EpicCare ticket and got routed over to him.

I can’t recall any documentation other than in the online help.

Thanks, just entered a new support case, maybe this time they will help lol.

So I finally got into it, and actually was able to make some recipes, but I still can’t set up the connection to our kinetic environment. Epicor says its a networking issue but I’ve already had our IT folks whitelist the addresses listed on the Workato site and still getting this message. Any ideas how to resolve it? Or find out what is getting blocked? We are on prem but not using the OPA.

That URL you provide for your connection (Your ERP) must be accessible from the internet so Workato can talk to it. Most of us set up some sort of DMZ with a second appserver to protect the on-prem production servers.

It looks like Epicor/ Workato can’t hit 443 on that URL from outside. For what is worth it living inside epicor isn’t necessary we never setup ours. We just go to and work from there, the integrated thing is nice, but its all IFRames and it can get a little scrolly…

I can access automation studio and create recipes from within Kinetic AND from I just can’t create a connection to Kinetic from within automation studio. Not sure I am explaining properly. It seems like the network access must be sufficient or else I wouldn’t be able to use automation studio from within kinetic at all? The error is just occuring on the individual connection.

1 Like

Wide open? Meaning accessible from ips OTHER than those listed in the whitelisting doc? Why would that be?

No, just from the Workato IPs.

Yeah so I think workato ips must have access or else I wouldn’t have gotten this far . . . trying to understand what else can be the problem.

Check with your IT and see if they have a port forward from a different port than 443.

We don’t even have our epicor in the WAN (at all) and I was able to register it just fine, we don’t even have 443 open. It does it all on the client (browser)

1 Like

I just did again ran it through Fiddler Classic and these are really the only calls that are made (all from within the browser / client)

It basically

  1. Logs in to your Epicor
  2. Gets a Token
  3. Registers the Service to the Instance


It all happens client side so there should be no network related things or issues you need to be dealing with. I wonder if your browser is blocking some stuff, do you have UBlock Origin or any weird extensions installed?

Can you try it in Edge / FireFox / Chrome (which ever you don’t have anything fancy installed)

Don’t have anything fancy installed. Using chrome, but I get the same result within the client as well. Those are the calls when you are on Projects/[Project]/[Connection] and you are clicking Connect?

Never mind I thought you were having issues accessing Automation (registering it) I see. So you are having issues creating a Kinetic Connection from inside a recipe…

So I just did some testing, you aren’t using an On Prem Connector Right? If so is your TLD resolvable from outside (DNS) the testing I did got the same result as you and is because DNS isn’t resolving properly.

If your server is

xxx.myinternal.local you need to have your IT Folks create an outside facing DNS entry that points to that (Public DNS) → maps 443 to xxx.myinternal.local

What is happening is that workato can’t resolve your server’s address. At least that’s my educated guess based in my own testing of our own internal address.

1 Like

I thought that’s what we already did but I will have to check with the IT people, thanks for responding.

Removing https from the server address fixed it :man_facepalming:

I wouldn’t call that “fixed”.