Barcode addition to SSRS Report Kinetic

Hi there
I have a report which I want to add a field to show as a barcode.

Ive installed CODE128 FONT onto my ssrs server, and also locally.
Ive altered the fields font to be code 128
I can see on the report design that theres a barcode:

however when i print preview its showing just text…

Ive also tried adding * before and after - but again showing just text

Where am i going wrong please?

Also, whilst on the topic - i know nothing about how barcodes work - can i add multiple fields into one bar code to one scan is made rather than multiples? if so what do i use as a separator between fields?

Ms. Carla: The standard Epicor Barcode font (DWBAR39) uses the asterisk as a prefix and a suffix.

The Code 128 has to be “Encoded” which means you cannot just use a string it has to be encoded. Were there any instructions that came with the Code 128?

I have used the IDAutomation Code 128 font in the past and they include some VB Code that you install in the SSRS Code section to “Encode” the UCC128 with your string.


No instructions - i simply installed the code 128 and data works font locally on my client and on server but does not work

I followed the instructions on the top answer from the link below to add Code128 barcode to SSRS

Ah yes i had folowed that solution and added the file ref - the code etc but still not work for me

Looking at my notes from the time the only extra step was a restart of SSRS

Hi you may have it working by now but I had the same issue and thought I had followed every step but re-did it making sure the font was Installed for all Users. See knowledge article KB0029155 in epiccare.

Thanks Gillian - i dont have epiccare access at the moment, i restarted all servers last night in effort to make it ‘see’ the font, still not working - and can see even the standard traveller which has barcodes does not show barcodes

if i run the report from the report builder using the table guid i can see barcodes! just not on the pdfs or print outs

Morning…this is the knowledge article resolution – hope it helps.

thankyou- i was missing rebooting after install for all users