Calculator tool not passing back result to Numeric field

Hello Team,

I have learn another little feature today, the ability to right click on a numeric field and select Calculator tool.
image

The numeric value would be copied into the calculator screen, then user can do it’s calculations and by clicking OK the new value would be placed into the numeric field.

BUT for one user who extensively uses this, she had two issues.

Issue one: Selecting the calculator was giving a stringtonumber conversion error:

image

I noticed that the user Windows decimal separator value was set to comma. I changed it to a period, and it resolved the error. (showing that the conversion is not taking into account this setting)

But now there is issue2:
When the user does the calculations and presses OK, the result is not transfered to the numeric field.

Moreover, even if the user is correctly setup with a period as the decimal separator, it shows a comma into the numeric field. I beleive it is causing the issue…

Question: Where is this changed in Epicor? My assumption would have been that it uses the Windows setting… but does not seem to…

Cleared the cache
This happens under base version as well
This is not happening to me, I have period decimal seperator all over…
10.2.300.11

Thank you.

Pierre

1 Like

First of all I had no idea that feature was there. Thanks for posting that.

I would assume it will be either the “user account” settings in Epicor under the Format Culture or windows lanuage and region settings.

Thanks DAN that was it…the format culture.

we use French language, but to have the period, we need to use English format culture.
Change it and all worked as expected…

Thanks to point me to the right direction!

Pierre