Increase decimal point precision

I have a number field in a form with 2 digits of precision for which I created a customization and changed the format to 4 digits. It displays correctly but the value still only saves 2 digits of precision. Is this something that needs to be changed in the database? If so, what are best practices? I have read in other threads that direct changes to the database can create predictable behaviour.

Not sure how you created the number field. If it is a UD field.

For User Defined Column, Use UD Column Maintenance to change the decimals to 4.

Regen the model on the server

Check the SQL server to see if the database data type been updated.


Thank you for the reply.

I am working with Operation Standards. In order for costing to match the existing ERP system, I need to be able to input up to 4 decimals in setup hours and I need all the math to use 4 decimal points without rounding. Here is what I did in an attempt to input up to 4 decimals.

Check the Extended Properties of that field.


I just tried changing it in Ext properties, and get:


So I checked the Data Dictionary, and see that the field only holds 2 places.


Also … Setup is in hours. so going to 3 decimal places would 0.001 Hr = 3.6 seconds. Do you really need this fine a resolution?

The current 0.01 hr gives you 36 second resolution. You need to be more precise than that?

No. I would like my boss to open his mind to something new. It’s been years since they started this project so I doubt I can change mind. I am new to the company and new to the Epicor.

That is exactly the problem. I got the same result. That leads me back to the original question regarding if I should modify the database and if so, can someone point me to the appropriate documentation. Any insight into issues I might have in doing so would be helpful.

So somewhere a calculation is done using SetupHours and some labor cost. So the standard setup labor cost is limited to by the resolution of the SetupHours. I.E 10 minutes is 1/6th an hour, or 0.166666666… hours. But you can only enter 0.16 or 0.17. Making the time used in the calc either 9.6 min (9m 36 s) or 10.2 min (10m 12 s).

And when setup time is reported i is saved with a higher resolution than can be entered in the standard?

Correct. For one standard, we can do 800 operations/hour. As the number of operations required for a given part goes up, so does the error.

This is what I believe the math looks like:
((CostingLaborRateSetup) * (Setup Hours)) + ((OperationPerHour*NumberOfOperations) * CostingLaborRateProduction)

But is there a setup time required every time that operation is performed?

Like if I have an operation to drill a hole, and it takes 1 minute to swap the bit, and I have 800 operations to drill that hole, I don’t need to change the bit everytime. Maybe make two operations. One to setup the machine, and another to actually do the operation. The first would have your setup time in it, and the second would have no setup time.

Correct. I misspoke before. The problem doesn’t scale up. It is a fixed cost.

I am pushing back on my boss. I think it would be easier to build a spreadsheet to show why the error exists.

You have talked me off the ledge. Thank you.

1 Like