DMT: Deleting all Memo for a part

We have a part that is used as a template when Engineering creates a new part. There are over 90 memos attached to it created since 2014 where we were in our learning phase up to 2016 when we went live.
Every time a copy is made, all the momos get copied as well.

I mad a sql query for that part and created a csv file for the dmt process.

I tried to delete the memos via DMT and getting the following message:

What values should I use for the BOName, and the Key1ColumnName ???

Thank you


DMT doesn’t work for memos. At all.
See EpicCare problem: PRB0242993
I would love to hear when this is working properly.

Actually, If we show all the memos when we are in this part view, and delete them by hand…, they no longer show …in Epicor…
They are all part of the Ice.Memo table !!! still… the reason I want to delete!

(I know it is not allowed… but a Delete in mssql would probably work…:wink: )

That is weird. I wonder why they do it that way? I have never tried deleting with mssql. You could also try with a UBAQ. I expect there is something special about the memo table that is causing the DMT to not work, and causing that other issue you described.

I wonder if they could be deleted with an updatable BAQ… Also, the DMT folks were responsive on fixing bugs back in the day. I haven’t had to request any fixes there, lately though…

1 Like