DMT on Job Prod

I am trying to update the Warehouse, but it keeps on telling me that JobProd not Found.

I even did a JobHead first to Unengineer.

I experienced the same problem a few times… very strange but change your column order to:
Company, Plant, JobNum, PartNum, MakeToStockQty, WarehouseCode, MakeToType
There are a few DMT loads that for some reason the column order matters.

Thanks for the suggestion Rick, but that did not work for me.

What is required in the UI to make this change? The best thing I got form DMT training was to do the steps in the app, so you knew what data was needed.

Look at the trace for values that were used.

In the DMT template MakeToStock is has only valid when ordernum = 0 and I looked in my templates and I had ordernum, orderline, orderrelnum all as 0

Greg

Sorry, I was too quick to answer, I think I have it now…
Had to do this last January when we split a company into two companies.
I have reviewed my DMT Complete logs
Here is the correct DMT Load sequence:
JobHead, JobPart, JobProd, JobAsmbl, JobOper, JobMtl

It took me several attempts to figure this out… some of the data seems redundant, but this is the order that I am pretty sure ended up working for me.
Let me know.

In addition to column order, I notice that your Plant says Mfgsys and it’s probably MfgSys. I have heard that case can cause issue with plant codes.

Mark W.

Miguel,
Were you able to figure out the DMT load?
Curious what the solution was.

There was about 200 jobs, between 2 planners and myself we changed all the jobs in 1 hr. So I didnt find the solution, but will call EPICOR DMT Support next week.

Sometimes manually saves more time ha ha ha

1 Like

I apologize for resurrecting a long closed thread, but I have some useful information to add after stumbling upon this while googling for the exact same problem. I was trying to Update the JobProd table with exactly the same columns as the OP, and getting the exact same error.

What I ultimately realized was that Update didn’t work. I had to DMT Delete any existing Demand Records, then DMT Add New my updated records. Also, for what it’s worth, I had to use an extra column on the DMT Add New… It was MakeToStockQty.

So my DMT Add New columns were:
Company
Plant
JobNum
PartNum
WarehouseCode
MakeToType (STOCK)
MakeToStockQty (This could change depending on MakeToType)

Again, I’m sorry for the necro, but this information would have been useful if I had found it while searching.

2 Likes

Good info.

In case someone needs to do this again in the future:

Tried this same activity today and was able to get Update to work for changing warehouse codes.

Fields: Company, Plant, JobNum, PartNum, MakeToType, WarehouseCode (existing), NewWarehouseCode

image

Forgot to include that you will need to unrelease the job first, update, and then release.

Job Header templates:

To UnRelease:

image

To Release:

Hi Rick,
i am stumbling at the JobPart DMT load as we are using Co parts, can you send me the columns you used? I tried with only Company, JobNum, PartNum, ths qty’s doesnt seem to work

Michel