Edge Agent Mass Deployment with an options file

Has anyone mass deployed the edge agent for browser first 2023.2?

We tried using an options file to fill in the parameters that would be our URL as well as the path to the client…it installed the edge agent but did not fill in the parameters correctly. Epicor told me that they have no released silent install for it yet and is targeted for 2024.1…


1 Like

What exactly you specified and what was not filled correctly?

1 Like

We did using some software. and help from this wonderful person above me! @Olga



We are using this script to install the edge agent for mass deployment:

\“server”\ERP11.2.400.0Deployment\ClientInstaller\edgeagent-kinetic-windows-x64-installer.exe --optionfile “\“server”\ERP11.2.400.0Deployment\ClientInstaller\edgeoption.txt”

Then we are using this for our option file:

allowedURL=https://“our server”/KineticTest

When they try and launch an application that is using classic they get this message:


So it seems to be installing the edge agent but maybe it is not linking to the path to the client??

I ran your file and I see the value in the “C:\Program Files\Epicor\EdgeAgent\edgeapp\appsettings.json”

      "ClientExecutables": [

So it looks like the value is filled in as expected.

Hmmmm. Maybe I will compare one that is working to the one that isnt working. Hopefully this points me in the right direction. @utaylor do you know if this is a similar way you mass deployed the edge agent??


Would having the client installed but not updated before we install the agent for the client path have any impact on this? It just seems weird I talked to our IT Manager and he said he compared that appsettings file and it was the exact same with one that was working and one that was not working.

Think we are going to do some testing on some fresh VMs and I will report back if we find a solution.

idk for sure, but it could be the case.


Do you know for a fact that the options you installed it with are the reason for your error?


I do not. It seems clear that the options it is installed with are not the reason for the error but also I am unsure why it is working for some and not for others.

What we do know is that anyone who had installed it themselves it works, the ones who had it mass installed some it does work after talking to people and others it does not work.

That is why I am thinking maybe it has to do with it maybe being installed before they have even launched the client? Would make sense that it would error out if the client hasn’t updated yet.

Probably EA is trying to talk to smart client and old version does not know anything about it. So no reply received.
From EA point of view it is the same as nothing installed.

Update: It is mandatory for the client to be installed and ran first to let it compile and auto update. Then you can install the edge agent and runs perfectly!


Thanks for the insite!

Hey @Olga looks like there is a bug. Took us a while @josecgomez and @jgiese.wci to narrow down.

We are in KineticDevelopment and it doesnt pick the right Client.

Notice string text inside of the for loop, gets the right value but string text2 outside of the loop just goes back to index 0.

You know how to report bugs, right? :laughing:
It is not here.
I did not look in this code myself.

1 Like

Automated System Message: User hkeric.wci token has expired and is unable to read posts for 48 hours.

1 Like

We’re setting context so when support tells us it’s not a bug… :wink:
Case CS0004201576 for reference LOL :smiley:

I neither confirm nor deny this is a bug :smiling_imp:

I am always confused if it should be a Ticket or an Idea. That’s all… Its easier to tag Olga and @JeffLeBert for them to atleast confirm its a bug, before I lose my soul going through Tier 1, Tier 2, Problem, Ah Its Not a Bug. :smiley:

Edge agent can have up to four application servers. What is the syntax to setup the Options file for multiple? Is it commas like below or some other syntax?