Epicor 10.1.400.18 MES Autologon

I am assuming there is nothing different about auto login for MES in E10. The config settings look the same as Epicor 9.05. Is there anything different I should be aware of?

You have to Allow Save Password in the Password Policy Maintenance. (System
Setup > Security Maintenance > Password Policy)

At some version of 10 (can’t remember which), they started encrypting the
password in the config file. So you can’t open a config file and edit the
user name and password directly like you use to be able too. You have to
click the Automatically Sign On option in the Preferences.

Which adds the entry to the config file and encrypts the password, like
this:

If you mess with the password in the config file, Epicor will reset both
UserID & Password to blank.

Thanks,

Norman Hutchins
System Administrator
Howell Laboratories, Inc.

6 Likes

How do you enable Automatically Sign On for MES users? I don’t see a setting for that in the config file? Do I have to logon as them in the full client to get to the Preferences you show below?

I had to log into the normal Epicor and set the auto login in Preferences
there, which will work the next time to open MES on the computer.

Thanks,

Norman Hutchins
System Administrator
Howell Laboratories, Inc.

1 Like

In order to log in as the MES user, I had to disable Single Sign on. When I log into the full client as a MES user, I don’t have rights to change the Preferences for Automatically Sign On. So, now I have to give the user rights to change this and then take the rights away afterwards? There has got to be an easier way to do this.
[/uploads/default/original/2X/c/cf7520ec48381eabb63b7ea0f9cf83257be96e15.png]

​I’m not sure, as we are not using SSO (yet). Maybe someone else has ​done
this before.

Thanks,

Norman Hutchins
System Administrator
Howell Laboratories, Inc.

The first part is correct, but, taking the rights away afterwards is not required. The only thing that allowing a user to automatically sign on does is to allow them to automatically sign on so there wouldn’t be a need to remove that ability.

Configuring automatic login with MES in 10.1.x is, um,er, ah,well,golly, less than ideal. For those that feel that allowing an MES user from within the MES client (or handheld) store the auto-logon information in the .sysconfig file please open a Support case and ask that it be associated to SCR 181103 / problem PRB0106900 so development can prioritize getting this into the product sooner.

Here is what we did, right or wrong:

Epicor 10 does not allow you to modify the Config files manually. To setup Automatic login into MES Epicor, you will need to do these things:

  1. Disable Single Sign On for each of the MES accounts in Epicor.
  2. Enable the ability to save passwords in Password Policy within Epicor.
  3. Log in to the FULL CLIENT as the MES user on each MES touch screen.

[/uploads/default/original/2X/6/60995217849059177cc75fedaa489ff09ac2497c.png]
4. Make sure you log in with the Classic Style check box Unchecked:

[/uploads/default/original/2X/e/eed5e6b659a24b71fcf21fb25bbde17c4d111ef5.png]
5. Epicor will state the user only has two more times to log in with this password. Go ahead and reset the password using the same password for new and old.
6. Once, you are in the full client, go to Settings:

[/uploads/default/original/2X/6/68d97b9e921fde4ac2bcf270e58c674617127431.png]
7. [/uploads/default/original/2X/b/bf388a204a7e9db30c5b35b480f138bf6a5fca11.png] Then go to Preferences:

[/uploads/default/original/2X/c/cbdc5bb84d59453fbc9e6bc2e40a5626e138c554.png]
8. Under Preferences, Check the Automatically Sign On check box.:

[/uploads/default/original/2X/d/dc0b7cd4b941d65891347cef847217fddb9f58f2.png]

This check box will write their user name and scrambled password to the config files.

  1. Press the OK button and exit Epicor.
  2. After all of the MES screens are set up, recheck the Single Sign On check box for each MES account in Epicor.
  3. Restart the MES touch screens and make sure they come up and log in automatically.

Those setups sound about right, and yes it is long and drawn out and has to be done on each MES machine. I also hate to be the bearer of bad news and ruin your Friday afternoon, but in my experience, this has to be redone after every upgrade as well…

Maybe this has been changed since 10.1.400, @aidacra?

The process to set the automatic login information in the.sysconfig has to be completed whenever the release level changes–for example, 10.1.400.x to 10.1.600.x.

Update for Version 10.1.400.18. After checking the Automatic Sign On, do not go back and check the Single Sign On check box in the User account. This wipes out the settings in the config file and pops up an error stating single sign on will not allow you to login. Strange behavior but it works fine when the Single Sign On is unchecked.

From Epicor:

In E10.1, Single Sign On works differently than it did in E9.05. You have two options.
First is Automatic Login, which will store a username and password in the local .sysconfig file. That username and password will be be encrypted in that file. It means anyone who logs into a client using that .sysconfig file will login as that user.
Second is Single Sign On. This matches the E10.1 user to the Windows username and only allows a successful login if the two are linked.
Unfortunately, in E10.1, you will need to choose one or the other for this MES workstation