Epicor Application has stopped working (10.2.400.13)

I have a sales rep who does most of his work using the Order Entry utility.
He reports that Epicor has been crashing on him, sometimes as often as 6x/day.

I opened his User profile alongside that of another sales rep, who has not been experiencing crashes. Their security groups aren’t a 1:1 match, but I don’t see any other clues as to why only one of them is having this kind of trouble.

After browsing Epiusers for a while, I saw that “Delete Personalizations” is a frequent suggestion when a problem like this is presented. I deleted the rep’s personalization file, and he reported continued crashing.

I deleted the personalization file a second time, and asked him to see what happens when he works for a couple of days without personalizing any of his views. No relief. The crashes continued.

I asked the rep if he’s observed any patterns: what he’s usually doing when a crash occurs. He noted he’s usually entering order lines. Late last week, he was 20 lines into entering an order when Epicor crashed, and he had to do it all over again.

Posting today to see if anyone has other suggestions, apart from deleting personalizations.
Places to look for clues as to the root of the problem, variables to test, remedies to try, anything.

Thanks again.

P.S. Apparently, he was using Order Status Browser (not Order Entry) when he took the screen shot he sent me, copied below.

Delete the folders at these two paths. Sometimes these files get hosed up and cause issues

  • C:\Users{insertYourUsersUsernameHere}\AppData\Local\Epicor\Epicor.exe_StrongName_blahblahblah
    Delete the StrongName Folder

  • C:\ProgramData\Epicor\epicorap-808
    Delete the folder relevant to the environment they are having issues with


We had a similar problem, one thing that we noticed was that it was only happening to users that were using low end laptops with 4g of RAM


I deleted the StrongName folder, as @cfinley suggested.
Was not able to locate any folder with a path like C:\ProgramData\Epicor\epicorap-808.

Looked into the specs of the computer(s) where the user does his work, as @LBARKER suggested.
All machines he uses have at least 8GB of RAM installed.

I also had the user Clear Client Cache, from his Settings menu.

As of this morning (7/1), he was still experiencing crashes.

Here’s where I had a wild idea.
This guy is a sales rep, who is assigned to 3 access groups in addition to Inside Salesperson.
Our other reps are assigned only to the Inside Salesperson group. No others report crashing.
After confirming that the 3 extra access groups were more relevant to a previous role of his,
I removed his profile from these groups, just to see if it produces any change.

If anyone has ever heard of particular combinations of Access Groups creating unexpected conflicts for individual user profiles in E10, I would be very interested in hearing about your experiences.

@Riggs You definitely can and should delete anything below C:\ProgramData\Epicor with Epicor closed. It will be rebuilt on the next open.

The install is not machine dependent. We were asked by support to copy the folder from a good machine to a bad once to rule out the install, so now we do it if we need to eliminate it as an issue. Rename the original folder if you want to switch between them.

On the user idea, does your user fail on his machine and his fail on yours?

If you turn on tracing you hopefully would see the last thing before he crashed. You can also take that tracing file and run it thru the performance diagnostic tool Client Trace Analysis to see every call he made. It takes a while to process. I just did a 600MB trace file in 5 minutes.

Do you have serverlog on? I run Verbose, BPM and detail exceptions, so I can go back to the server and find the log to check. You will have to calculate your time to UTC :slight_smile:

1 Like

For stubborn problem computers, I’ve created a .bat file that I run as admin on the problem computer

It’s like a brute force Clear Client Cache, make sure Epicor is closed before running it

@echo off

RD /S /Q "%APPDATA%\epicor"

Epicor-delete-user-settings.bat.txt (109 Bytes)


You definitely can and should delete anything below C:\ProgramData\Epicor with Epicor closed. It will be rebuilt on the next open.

I can try this in the morning when I can confirm with the user that he has definitely closed Epicor.
I managed to find C:\ProgramData\Epicor, after all.

I had mistakenly believed that the sales rep had run E10 on a computer at his home, and a computer at the office. But it turns out he only ever RDP’d into the office machine, when he worked from home.

If you turn on tracing

I suppose that’s what Enable Trace Logging must mean, right?

Do you have serverlog on?

I’m afraid I don’t know. Where can I look this up? :grimacing:

1 Like

Is he having any other network connectivity issues? Saying that he he was 20 lines into a sale order and had to start over sounds suspicious. Each line should have saved automatically as soon as the next is created.

1 Like

Actually…“and had to start over” may be a detail I added in the retelling, without realizing how much of the story it changes. I don’t believe he used those words.

Gotcha. Did you check their . Net version? Is it consistent with other users computers?

1 Like

I have always done tracing from the client side and viewing the file from there. It is the icon next to developer in the interface you are using.

image001.pngIn Shell at the bottom


If I am programming then I do clear log – apply then trace and view, so I have this open a lot. You may want to do that with this user so you only get the sales order entry entries. For some users I will just leave it on all day.

Appserver setting are in the Admin console. The ServerLog.txt file is made in the inetpub\wwwroot[Server Name]\Server folder



It will popup a warning. It does not have any impact on users.


1 Like

.Net version

The sales rep, and the rest of us, are on .NET Framework v4.8.
Any idea as to what’s the lowest version number suitable for running Epicor 10?

I believe 4.8 is the recommended version still

On his machine when this error happens there should be something in the event log

What do you see?

1 Like

I’ll throw my hat in with other suggestions. Make sure his AV is not smashing his Epicor and the other folders mentioned in earlier posts.

Does the user have personalizations for the form(s)?
If so, I might try deleting those too.

Also, I remember seeing problems with intermittent network connection issues.
And that it was a pain to nail down.


I don’t think I spelled this out before now, but my sales rep has been working from home,
using Remote Desktop Connection to run Epicor on a computer located here at the office.

The last thing we tried was to set him up to remote into a different computer.
As the rep ran Epicor on a different computer (also located here at the office),
I remoted into the computer the sales rep had been using earlier, and did some testing.
Only one of us experienced any crashes while using Epicor via the remote connection.
It was me!

We’ve got the sales rep remoting into the second computer permanently, now.
As for the original computer, we will uninstall and reinstall Epicor as time permits.

Thanks so much to everyone who contributed suggestions. This one was super frustrating!