Epicor Client HTTP deployment

Does anyone know if Epicor removed HTTP as a deployment option in 10.1.500.X?
In 10.1.4XX you could set the deployment to HTTP and it worked just fine, however setting it to HTTP on 500 I keep getting this message

Assuming I haven’t’ forked anything up, does this mean that HTTP deployment is no longer allowed?
And a follow up question, is there another option for WAN deployment over HTTPS?
@Bart_Elia @Edge @aidacra

ftp, http or network share. Just change the url in sysconfig deployment setting.

Yup that’s the way we’ve been doing it for ever (10.1.4XX) but for 10.1.500.7 it isn’t working (getting that error Above) if I use \Server\ it works fine (locally) but if I use http or ftp we get that error… I am showing you.
I can browse to the URL fine
Current settings as follows

URL works, I can browse over to it (below)

Using fiddler I can see it hitting the Config URL and then it gives me the above error.

I reflected into the AutoUpdate.exe and didn’t see much its choking on StreamHelper class
Same exact configuration worked / works fine for 10.1.400.19

Get it in through proper channels. Should work :confused:

I got it to work… for future reference

The AutoUpdate.exe only supports http, not https

The issue I was running into was that the server config in http://myserver/deployment/client/config/myconfig.sysconfig was pointing to https. So even though my local AutoUpdate.exe was requesting the initial config from http, as soon as that config downloaded it re-read the sysconfig settings and tried to continue from https which throws a not supported error.

a couple of suggestions, since this is deployment most suited for WAN deployment why not support https? You get it for “FREE” if you use the WebClient or any of the standard .NET classes and it would be nice to have it all wrapped in a nice secure tunnel, documentation for this stuff would be AWESOME!

Also it would be great if the Epicor Client Installer supported http, currently it asks fir \SEVER\Deployment and it will not accept HTTP URL as an option. Is there an alternate Client Installer?

Thanks @Bart_Elia

1 Like

Agree HTTPS should be supported - submit an SCR.

I just tested HTTP but looks like Bart beat me to it!
Adding a Deployment folder as a Virtual Directory is a nicer way to go also instead of the share.


Yes that’s what I had done originally, Virtual Dir :slight_smile: works well when you stop trying to do HTTPS head slap

The biggest issue is having to download (somehow) the initial AutoUpdate.exe for the rest of it to work. It would be great if the standard client install supported HTTP

Yes and remove the need for UAC which is on my personal agenda!