Epicor Speed Differences

So, I’m down in Mexico right now testing out the speed of our Azure server.
It runs great for me, but for my Mexican counterparts, it’s painfully slow.
We’re on the same WiFi, same instance, etc. The only difference would be the hardware, mine is higher end, but they’re not that far off 16gb RAM vs 8gb and 2.80ghz CPU vs 2.10ghz.
What I’m noticing is that the initial opening of Epicor takes 2-3x longer than mine.
Each form that’s opened is 2-3x times slower than mine the first time, then it’s faster.
(Sounds like caching to me).
My thought was it was going to continually be fast after that initial load since everything is now cached, but if I close Epicor and reopen it, it’s just as slow as the first time. Each module is also just as slow and I’m not seeing the “Caching” that comes up when it’s pulling from the server.
The users are not local admins, so the folder has full control for the Local\Users security, but this is set up the same way on mine.
What else can I look at?

Do you have the Mexico ‘layers’ in play? Translations, localizations, etc. that might be taking some cycles?

We both have the same translations and localizations loaded.

Hmmm… could be that new tariff Trump is putting in place :slight_smile: just kidding…

how about anti-virus or anything else their installation of windows is running that you are not?

I’m not sure how Azure really works with the distributed data/servers and all, but are you both on the same appserver? if you traceroute to the appserver are you both on the same path? I’m thinking there has to be something between you and the data that is different for them to cause the diff in speed.


All I can think of is that they have additional security software, or they are connected to a different hotspot, or they are on a different Domain Controller than you as a Guest via Direct or VPN.

We had misconfigured Firewall Hardware cause slowness at 1 site. It scanned packets, all packets. Once we whitelisted our IPs stuff went fast. SonicWall/WatchGuard

Basically if your Epicor to App Server packets are slow (latency), so becomes the entire software. Whitelist the IPs, Exclude Directories from being AV Scanned in Real-Time …

I am sure since you are now going to Azure Public IPs their internal Hardware is probably seeing that as “Network Traffic, that should be scanned”.

Yep - what he said, too.

Ahhhh–this may be the ticket! They just recently had some issues with some wormies, so they installed CrowdStrike hardcore on everyone’s. I will check into exclusions and report back if that helps.

There is another post on crowdstrike being problematic here as well…

I’m actually a part of that convo. :slight_smile:
His was server-side, though, and mentioned there were no issues with E10.
We don’t have an antivirus on our servers yet.

LOL - didn’t check if you were, just remembered it enough to do a search for it…

When in doubt tracing plus pdt are your friends

1 Like

Well, that confirmed it’s slow, lol
Now what do I do with this data?

Go with your laptop and a Ethernet cable directly to the Modem / Gateway, bypass all Switches, if its still as slow, then you work your way to the switches to find misconfiguration.

Like I said if you “filter or log” any traffic what-so-ever going from Local to Azure - It will be slow as snails… Of course since the Azure IP is external, your firewall treats it as a threat (lets analyze this before we go out, lets analyze this before we come in). There has to be a place to mark your Azure IPs as “free-flow” :slight_smile: fly little birdies, fly.

I’d start at the Gateway and work my way in.

1 Like

Wouldn’t the results be the same for my computer and other other users?

Assuming you are connected to the same Domain Controller… I assume they have a Local DC/Active Directory, so what if you Join their Domain Active Directory and then use WiFi. Maybe they have a VLAN Setting on the Local AD which is re-routing their traffic differently (tagging their traffic), than when someone just uses WiFi? Tagging VLANs cause QoS settings to fire etc…

Can you Exit your Corporate AD and Join theirs and reboot and receive their GPO, try then?

1 Like

Lemme give it a shot.

Also check what DNS Servers they use… Some Organizations do have DNS Servers that “Content-Filter” - CloudFlare / Cisco Umbrella… Once again that might be applied by the local GPO, so you might be using diff DNS Servers.

ipconfig /all

What if you disable ipv6 in TCP/IP Settings etc… I guess try to see if you can mimic 1 workstation as close as possible to settings, dns servers, both should be on the same WiFi, no VOIP Phone in the middle etc…

Also if you do tracert yourazureip what do you get

or even better run this utility on your laptop and a workstation and compare

1 Like

Joining their domain was just as fast; I’ll try the Ping Plotter next.

Also, the tracert had the same IPs for the first 3. On the next two, they were different, but the speeds were the same. The final was the same.

So, this is interesting.
After switching back onto my original domain, my Epicor is now just as slow as theirs.
What gives?

1 Like

Ping Plotters: