Error when opening Fulfilment Workbench from Dashboard using app-open widget

Hi there,

I’m trying to open the Fulfilment Workbench screen from a custom Kinetic dashboard I have created.

I have created an event on button click, which calls the app-open widget.

I’ve set the “value in” parameter to be:

	"OrderNum": "??{%currentDataView%.OrderRel_OrderNum}"

This displays the correct order number as a string when using dialog widget. (On a side note, the console-write widget doesn’t work for me at all…).

I need this value as an Integer for the FFW screen but whenever I do this, the FFW screen opens but returns the following error:

Conversion failed when converting the varchar value '[object Object]' to data type int. 

I can get the app-open to work if I just enter a literal number, but I want the user to select the row in the dashboard grid and then to use the button.

The JSON editor doesn’t seem to like single quotes at all. The lack of IntelliSense doens’t help much either… :frowning:

@josecgomez @hmwillett Any ideas from the gurus?

I would create a function that parses a string to an integer.
Call that function in your event, pass the string value into the function, then use the converted, returned integer to be your Value In param for the form open.

You could also do it inline with the row-update widget if you wanted.

Thanks for that, I still get the same conversion error, unless I’m doing something wrong?


The conversion itself works though!

So, when you run it and look at the DataViews in Dev Tools, it’s showing an integer value for TransView.StringToInt?



Remove the quotes from the JSON since it’s now an int:

    "valueIn": {TransView.StringToInt}

I do that and it gets a red squiggly line and says “value must be doublequoted”.

Can you try that and see if you get the same error?

So, you’re right–it needs the quotes despite the int.

I would look into this next.
Change it from %CurrentDataView% to the actual, bound view of the dashboard panel the user is clicking on.

For instance, if I cycle through my BAQ Panel and display these two fields:
{NewView.Project_ProjectID} | {%CurrentDataView%.Project_ProjectID}

I get this:
102 | {%CurrentDataView%.Project_ProjectID}

Tried both ways and still no luck!

I actually have raised a support request and I have a Teams meeting with Epicor about this!

I may be a potential bug! I’ll keep you updated!

Thanks for your Kinetics Wizardry (and the help)!

1 Like

If you’re willing, you could package your dashboard, baq, and Kinetic layer into a solution and PM it to me. It would be easier to work with your exact scenario.

@J_I Hi, were you able to find a solution for this? Running into the same problem.