EWA Error upon login after upgrade from 10.1.600.13 to

I have tested to upgrade my two databases of 10.1.600.13 instance to and tried to log into EWA. I did not test it on 10.1.600.13 but both databases seems to behaving differently.

One logs in correctly and allows to transact but the other instance gives attached error, goes to Loading and goes back to Login page.

Anybody else faced similar issues in past? I tried to lookup the past messages, but seems EWA is a rarely used feature among the users here.

Have you tried removing the instance that is not working and re-deploy?


Thanks, I had to remove the instance to make it work.

Actually, I had a ready VM where I changed the server and domain name and was trying to make use of the same ERP10-EWA site. Since the EWA Deployment was already done with previous server, the C:\ProgramData\Epicor\SetupInfo\ERP10SetupData.xml file was having old SUEWA settings. I had uninstalled the EWA Deployment with anticipation that the cleanup of the SetupData.XML will be done, but it was not and so it did not allow to create the site with same name. Manually deleting from C:\ProgramData\Epicor\SetupInfo\ERP10SetupData.xml helped to clean previous settings, start afresh, and it worked well.

Thanks your direction.


I know some time has passed on this, but I wanted to add some extra info to the post because the symptom looks the same and it may help someone down the road. Copying files from one EWA install to another and updating the web.config is as simple as it sounds with one gotcha that will result in a similar error message at the login screen like the one you reference here.
The file wwwroot\YourEWAInstall\script\global.js contains a hard-coded link to the host name on line 4: var g_HostURL = “YourEWAInstall”;
Update this and restart iis and the links should be corrected without having to reinstall.


@josephmoeller Nice catch