Gaps in QuotDtl QuoteLine and DMT

It appears that DMT ignores the QuoteLine field and just uses the first unused number. So gaps in the source data make the target out of alignment with the source.

For example: The following data was uploaded using Quote Detail (Phase 5 \ Customer \ Quote Detail):

But the data in E10 appears as:

Note that the source was missing QuoteLine’s 4-6. But the result after import put line 7 as Line 4.

If I run process the Quote Details again, it creates a new line as line 5 (the next open line number), with the values from “line 7” of the source

What I’ve been doing is to compare the source data with a query of E10, find missing data, then upload the missing data. This may take several iterations. Then after all of the source data is in E10 , I have to find the data that is in E10 but not in the source. In my example, this would be Quote lines 4,5, and 6. Make a table of those lines, and then run the Delete process in DMT.

Am I missing something?


PO and SO DMT load does the same thing going back to E9.05. I was hoping
this would be fixed in E10.

I had previously discovered the Customer and Vendor do something similar.

Even if you include the CustNum, it ignores it and just uses the first available number. This then requires that all your other table that naturally reference CustNum actually have to export using the CustID instead.

I think the reason is the logic cannot skip numbers. If you were updating it would be something, but creating a new quote line follows the same logic as the application. You cannot create line 7 without skipping 4-6 in the application.
that’s just my 2 cents.
good luck,

I figured as much.

But I guess it would be nice if DMT were to Create the new record (with the incorrect LineNum), then check if record created matches desired record. If it does not, then flag the record just created for deletion, and try making the record again. Continue this loop until new record matches desired one. Then go back and delete the records flagged for deletion.

Sales OrderDtl and PODtl work the same way. If you have gaps in line numbers, dmt will shift the line numbers. This can be an issue when importing releases, which would then be linked to the incorrect line number.

Get Outlook for iOS

Yeah this is not “DMT” as much as it is Epicor. DMT uses the standard business objects to import, and Epicor doesn’t allow you to have arbitrary gaps in those sequences.
The same will happen with PO, SO, Packs

I usually look for gaps and remove them in Excel using a formula that adds +1 to the line number before it to create the next line. You could also run a macro in Excel to build the gaps, and then delete them after DMT import is complete. I have sample code if anyone is interested. That’s twice or three times the amount of work as just plugging the gaps during the first pass.