Issue with upgrading client from 10.1.400.10 to .32

I am trying to upgrade the client from .10 to .32 and it worked correctly on the app server but when I run the client on a workstation it just gives me a version mismatch and closes. How do I force the client upgrade?

Make sure the shortcut on the client doesn’t have /SKIP

I checked that and it does not.

Open the client config (in the workstation you are trying to update) and change the version number to and then try again. Is this happening in other workstations?

Couldn’t he just run AutoUpdate.exe?

Running AutoUpdate.exe without /config and a bunch of other settings will clear his client folder but not update it (in my experience)


Where would those settings be located?

They are passed as arguments to the AutoUpdate.exe /config /folder … etc I don’t know them out of the top of my head.

So when I try to run the autoupdate.exe I get the error that it can’t find the default.sysconfig file. What my client is trying to target is the ERP101400.sysconfig file which is there. On the server client that updated correctly it is also pointing to the ERP101400.sysconfig and it updated correctly when logging in for the first time.

Like I mentioned running AutoUpdate.exe by itself is difficult, if you change the version number on your sysconfig in the client workstation the autoupdate should run on its own.

You could just copy the ERP101400.sysconfig file and rename it to default.sysconfig and then re-run AutoUpdate as Administrator.

Edit: So make two versions of ERP101400.sysconfig and just rename one to default.sysconfig on the client computer

What would the harm being in deleting the whole folder and reinstalling? Maybe that was tried already.

On the client computer? Not much harm in re-installing it…
Before re-installing try doing the thing I said above and see if AutoUpdate picks it up

Edit: Did you also try the thing that Jose has suggested? I did try this in my environment and I didn’t get an update, although I don’t have anything new on the server

I just reinstalled the files on the client and it seems to be working now. kind of a pain though. For some reason the upgrade didn’t run when the client opened epicor. Maybe I missed a step on setting up the update processes for the client machines.