Version Mismatch

I tried making an update to the Live.sysconfig file and pushed it out to the users by updating it in the \isiepicor\ERP10.1.500.0Deployment directory. The clients start updating, but at the end I get the message saying there’s a version mismatch.
I looked at the config file that deployed and the version shows “10.1.500.16”.
In the end, I fixed it by running my deployment batch file which xcopies from the server to the client.
What went wrong? How come the update didn’t work?


The error occurred due to .dll files in the local client folder being the incorrect version.

That’s why you were able to fix it by updating from the server. If you just update the sysconfig file on the client it doesn’t really mean much. The client needs to grab ALL the new files from the server

But when the user opened the Epicor Client, it did the update routine and pulled the files from the server. It just didn’t work at the end.

You said “I fixed it by running my deployment batch file which xcopies from the server to the client.”

Is the deployment server/package information setup correctly? As in, is it grabbing the files from the same location as your deployment batch file?

Edit: The deployment server/package information being incorrect (typo, fat finger, etc.) is the only thing I can think of, since the autoupdate process basically does the same thing as your deployment batch process and copies the servers files to the clients directory

Okay, so let’s go with the assumption I messed something up (put the updated file in the wrong spot on the server, tweaked a setting, etc.).

What’s the proper way to push an updated client config file to all the users without running into this issue?

I am definitely not an expert on this, but my assumption was that when you needed to change something with the files that are being sent from the Server to the Clients you needed to re-zip the folder.

So to update all the clients wouldn’t you create the new on the Deployment server (matches the picture below from the config file) and then run the autoupdate program (or let Epicor run it for you)

So to wrap it up; you would take the updated (10.1.500.16) files and create the new file in the deployment server url and then run the AutoUpdate program. Then the autoupdate runs and if the config settings are correct, then it will grab the updated file and extract the files to the users C:\Epicor\ERP10.1Client\Client folder.

The AutoUpdate stuff may be optional- you might just be able to open an Epicor environment and then it autoupdates itself…

Recreating the in E905 and earlier was common to address various issues, but the in E10.x should never be changed.

Well–that may have been my issue as that is what I did.

What’s the proper way to push the updated client config file to all users?
I know I can send updates using the custom folder and updating the config to include the reference to the custom folder at the bottom, but how do I get them that updated config?

So if I wanted to change something minor in the configuration file and make sure that all users will have the updated config file, how would I without changing the If you never change that .zip, then where does AutoUpdate grab the new file/s from?

Edit: Now I’m really curious since I thought re-zipping/re-creating the was the only way…

There have been some changes in this area over the course of Epicor 10.x, but, generally, if one updates the server’s clientdeployment .sysconfig files \\EpicorServerName\ERP[Release]Deployment\client\config\

during the next autoupdate the workstations that have the client installed would copy the changes made to the server’s copy to the local machine except for any settings in the local workstation’s <userSettings> block–they will not be overwritten by a setting in the server’s sysconfig file.

1 Like

Sorry I am trying to follow the logic here and follow the correct procedure, but it just doesn’t seem to be working. I am trying to create a custom config file and I have the client already installed on my computer. I need to set a custom MES menu and change the login username to last instead of windows.

  1. In my local client config directory I copied the config file, renamed it and made my changes.
  2. I changed the shortcut on my desktop to point to the new config file (name only, not a full path).
    The problem - when I launch Epicor it says the file is missing from my server deployment directory.
    To solve the issue
  3. I moved (not copied) the config files from my local client config directory to the server deployment client config directory.
    The problem - when I launch Epicor again, it says the config files are missing from my local client config directory???

-When placing a new config file in the server deployment directory, is there some service/process that happens to put it into the
-When does the auto update kick off to actually copy the config file from the server deployment directory to the local directory? Is there a time frame I should wait and expect the client to update?
-What config file is the clients actually pointing to at launch, the server or local?
-Do I need to copy the config file to both the server and client to make an update?

For the autoupdate on the client to work, there has to be a sysconfig file with the same name as on the client on the server. Instead of your step 3, copy the sysconfig file from the client to the server.

One should never, ever touch the

I know this is old but I wanted to point something out. If Epicor.exe is open already on that PC (aka the file is in use) it will not update. In my case, I was on a terminal server and had to kill all instances that remote users had open.

Also, PS - We miss you @aidacra