Jobs missing in Time Phase

Hi everyone,

We are having an issue where jobs are missing in Time Phase. This is an example part, showing a job requiring Qty 1 and an MRP suggestion to make Qty 1.

However, the following job exists, is firm and has been scheduled. The job is ‘Make to Stock.’ For some reason it does not show in Time Phase. How can I get this job to appear? Thank you for any help :pray:

Hi Zane -

Do you only have one plant in Epicor? Time phased inquiry is site specific. It will not show jobs in other plants/sites. Any chance the job is setup in another plant?


Hi Nancy,

Yes, we only have one plant set up.

What are your MRP settings on the run? Here’s another post with some similar info… MRP - Not creating Jobs for some manufactured parts - #15 by Nancy_Hoyt

I am setting up MRP to run as follows, with no cut-off date.

Our parts all have ‘Process MRP’ enabled in Part Entry. The part is listed as a material on the top-level job, with ‘Make Direct’ unticked. (I understood that this means it can be fulfilled from stock/ existing supply jobs?).

Yes, if make direct is unchecked then the part demand should pull from inventory.

IDK if it’ll make a difference, but I like to check Dynamic on the schedule start date on the submitted MRP run, or an old submitted task can give unexpected results.

Also, I am unfamiliar with the new check “include only parts with activity…” I would just experiment to ensure that it is not causing the problem.

One other idea, perhaps you should try a run with “allow historical dates” checked to ensure that’s not the culprit of your job not showing up.

1 Like

Since the job was created, looks like MRP picked it up and created the job. What is the status of the job? Any chance it was somehow marked as complete?

Not related to MRP but i’ve had jobs remove from TimePhase before as well. For me it was when i DMT’d a change to the job, for some reason it removed it from TimePhase, i have to always run a 2nd DMT to uncheck Engineered/Released then a 3rd DMT to check them off again this makes the job appear back in TimePhase.

1 Like

@DKehler Woah, this is exactly what fixed it. I unticked Engineered and Released. Re-ticked both boxes and the job appeared in Time Phase immediately.

Thanks a lot!

I did notice another job disappear from Time Phase after I cleared the ‘Contract ID’ field on the job and re-ran MRP. Just tried the same fix on that one, and it shows now too.

I wonder why changes to the job are causing it to disappear from Time Phase…

Thanks everyone for the helpful suggestions.

1 Like

TimePhase is data from the PartDtl table. do you have bpms that could be causing an issue?