Part not driving demand correctly

I have a part that was initially set up as a purchased part and recently we decided to make it in house. I changed the type in the part master to Manufactured in part maintenance and ran MRP on it. I did this with a couple other parts as well and all of them worked fine with this one being the exception. When I time phase the part it shows a suggestion like its still a purchased part which it shouldn’t and there isn’t an actual purchase suggestion when I go to the PO suggestions entry. And there is no job suggestion like there should be like the other parts I just changed have now. I looked all over part maintenance and cant find any difference in how this one is set up compared to the ones that worked. I’ll manually make the job for this part but my concern is if there’s other parts doing this I wont know it because id only see it in time phase

Here are a few things to check:

  1. make the part is mfg on part detail and the set to mfg on the Part Site tab. (MRP use the setting on part site)

  2. toggle the the process mrp checkbox, save in-between settings

  3. Review time phase, make sure your demand records show up.

As Bryan said above, I am sure this is #1. We see this a lot. A part’s manufactured versus purchased status is defined at the site level, not on the part header. Think of it like this. If you have two plants that use the item, one plant would make it (so the part would be manufactured), and the other plant would buy it (so the part would be purchased). With that being maintained at the site level, this allows one part record to be planned differently at different sites.

I thought the same thing but i checked and the part is set to manufactured at the site level as well. My tim phase is still showing a suggestion as if its a buy part but that suggestion doesn’t actually exist. It’s acting like I made a change and haven’t run MRP yet which I have

Is the part marked as a Phantom BOM. Phantom BOMd and their components(Or lack thereof) can can strange MRP behavior

I suspect your part does not have a released revision of the method.