Kernelbase.dll Launching 10.2 client on Win 7

Hello all, I am having a really hard time getting 10.2.200 running on 32-bit Windows 7 machines. They are running .NET 4.7.2 and nearly all of them get the same application event log error. I am logging in as a domain admin so do not suspect any rights issues. Just wondering if there are any known issues or incompatibilities between 32-bit Win 7 / .NET 4.7 / E10.


Faulting application name: Epicor.exe, version:, time stamp: 0x5aa01345
Faulting module name: KERNELBASE.dll, version: 6.1.7601.24335, time stamp: 0x5c267ec8
Exception code: 0xe0434352
Fault offset: 0x0000845d
Faulting process id: 0x8f4
Faulting application start time: 0x01d4bd7ced98bca9
Faulting application path: C:\Epicor\ERP10.2Client\Client\Epicor.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 2b77438d-2970-11e9-b74f-ac162d05744c

which is accompanied by this .net runtime error:

Application: Epicor.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Runtime.InteropServices.COMException
at System.BaseConfigHandler.RunParser(System.String)
at System.ConfigTreeParser.Parse(System.String, System.String, Boolean)

Exception Info: System.ApplicationException
at System.ConfigTreeParser.Parse(System.String, System.String, Boolean)
at System.Security.Cryptography.CryptoConfig.OpenCryptoConfig()
at System.Security.Cryptography.CryptoConfig.InitializeConfigInfo()
at System.Security.Cryptography.CryptoConfig.CreateFromName(System.String, System.Object[])
at System.Security.Cryptography.RandomNumberGenerator.Create()
at System.MarvinHash.GenerateSeed()
at System.MarvinHash…cctor()

Exception Info: System.TypeInitializationException
at System.Xml.NameTable…ctor()
at System.Configuration.XmlUtil…ctor(System.IO.Stream, System.String, Boolean, System.Configuration.ConfigurationSchemaErrors)
at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()

Exception Info: System.Configuration.ConfigurationErrorsException
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(System.Configuration.ConfigurationSchemaErrors)
at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
at System.Configuration.ClientConfigurationSystem.EnsureInit(System.String)

Exception Info: System.Configuration.ConfigurationErrorsException
at System.Configuration.ClientConfigurationSystem.EnsureInit(System.String)
at System.Configuration.ClientConfigurationSystem.PrepareClientConfigSystem(System.String)
at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(System.String)
at System.Configuration.ConfigurationManager.get_AppSettings()
at Epicor.ServiceModel.Trace.ClientTracing.UserTracer…cctor()

Exception Info: System.TypeInitializationException
at Epicor.ServiceModel.Trace.ClientTracing.UserTracer.get_DialogException()
at Ice.Lib.Epicor.Main(System.String[])

Are you using username and password (stored in the sys configs)
The error appears to originate in the Config parsing, I’m wondering if you just have a bad sysconfig?

Do you have a file in the Client called Epicor.exe.config ? If so, rename it from Config to Tmp and try again.

No, I’m not using stored credentials. I have tried known good sysconfigs from my machine with the same result.

Rich, I did have that file but renaming it and relaunching the client appears to be generating the same error.

There is an EpicCare KB article that appears to be relevant:

I wish!!!

Try deleting any folders located within



%appdata%\..\Roaming\Microsoft\CLR Security Config

Is your .sysconfig file ok, not corrupt?

Yes, I have tried a couple of different sysconfigs including the one on my PC.

Just FYI in case anyone is still reading. I ran the .net cleanup tool from Microsoft then installed 4.7.2 by itself to fix this. Thanks again for all the great tips.

I just had the same issue after March 2019 Windows Rollup:
Perhaps: KB4087364

Epicor 10.1 and 10.2 affected on Windows 7 (Only me so far).

Resolved By:

  1. Uninstall (NOT Repair) .NET Framework 4.7.2
  2. Install .NET Framework 4.7.2

I also tried the Repair Utility, without luck. So a complete Removal and Install did the trick.

For Reference Error:

Application: epicor.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException

Exception Info: System.Reflection.TargetInvocationException
   at System.RuntimeMethodHandle.InvokeMethod(System.Object, System.Object[], System.Signature, Boolean)
   at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(System.Object, System.Object[], System.Object[])
   at System.Reflection.RuntimeMethodInfo.Invoke(System.Object, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo)
   at Ice.Lib.Epicor.LaunchMenu(System.String[])
   at Ice.Lib.Epicor.Main(System.String[])
1 Like