Kinetic Application Layer - extendedProp disabled icon appearing on slide out panel

I have created a customer Erp.UI.SalesOrderEntry layer with the following settings, effectively hiding “Attachments”, “Change Log”, “Memos”, and “Call Log” icons from the toolbar.

  {
    "Id": null,
    "Path": "/navigation/extendedProps/disableAttachments",
    "Value": true,
    "Operation": "Add",
    "Index": 0
  },
  {
    "Id": null,
    "Path": "/navigation/extendedProps/disableChangeLog",
    "Value": true,
    "Operation": "Add",
    "Index": 0
  },
  {
    "Id": null,
    "Path": "/navigation/extendedProps/disableMemos",
    "Value": true,
    "Operation": "Add",
    "Index": 0
  },
  {
    "Id": null,
    "Path": "/navigation/extendedProps/disableCallLog",
    "Value": true,
    "Operation": "Replace",
    "Index": 0
  },

When I preview the layer, the icons are not there as expected.

However, when I call the “Details” page on this same layer from an “isLink” on Erp.UI.OrderAllocEntry, the icons are there.

In addition, if I hide something in the overflow menu on Erp.UI.SalesOrderEntry, it’s still visible in the slide out panel on Erp.UI.OrderAllocEntry.

How do I get these settings to persist on the slide out panel?

Those are different forms.
You would need to create a layer for OrderAllocEntry, hide it there, and then have the app call that layer.

I have a custom layer for Erp.UI.OrderAllocEntry from which I am calling a custom layer of Erp.UI.SalesOrderEntry.

Based upon what you are saying, I would need to create a custom slide out panel on the Epr.UI.OrderAllocEntry custom layer that would be called by the isLink?

Don’t get hung up on the slide out panel. It’s launching a new form, but there’s a checkbox to allow you to open it in a slide out panel vs a new tab. Whatever form that slide out panel is will need the custom layer hiding those buttons.

For example, if I’m in Sales Order Entry and I have an event that fires and opens Part Entry in a slide out, if I want to do anything custom to that slide out, I have to do it in Part Entry and have the event on the Sales Order Entry side call that custom layer.

Okay. Good. So that’s what I think I have at the moment. My apologies if I am still missing the point.

I created a custom layer for Erp.UI.SalesOrderEntry (SOCustom).

From the custom layer for Erp.UI.OrderAllocEntry, I call SOCustom.

SOCustom isn’t showing the icons in Preview but is showing them when called in the slide out.

what does it say in debug when you call it? Is it requesting your layer?

The custom layer appears to be the layer being called. Note, I shortened the name of the customer layer in my previous post. The actual name of the layer is what appears in the log below.

This may or may not be related, but will absolutely bite you going forward: change the View to be the Menu ID (Example. OMT1000 or whatever).
They are deprecating the use of the program DLL name because it circumvents the menu security.

1 Like

Thank you for that.

If I use the Menu ID of a tracker will it open as a tracker? I also have a need to open as a tracker but can’t seem to figure out how to do that either…beyond the current issue at hand. :slight_smile:

Yes, it should.

Create a menu for Erp.UI.SalesOrderEntry and make sure the “Read Only” checkbox is marked in Menu Maintenance, then call that Menu ID with the app-open widget.

I made the Menu Item read only but it opens in the slide out in full edit mode :frowning:

In addition to the icons appearing when they shouldn’t.

I don’t know what I am doing wrong. I feel like I am doing everything the way you have counseled me to do.

In addition, if I uncheck “Slide Out” a new window doesn’t open.

Don’t be too hard on yourself, it’s hard to tell what’s broken and what’s not.

Can you show me how you wired everything up?

Should be similar to this:

Sure…one moment…I have to climb down from the ledge. :sweat_smile:

Doc Brown Fear GIF by Back to the Future Trilogy

I read edge instead so:

grandmaster flash 80s GIF

Don’t push me 'cause I’m close to the edge
I’m tryin not to lose my head :musical_note:

Let me test with your specific screens. Sometimes various screens are… difficult to work with.

@klincecum over there like

Bill Hader Popcorn GIF by Saturday Night Live